Bug 1301419 - rubygem-sinatra-1.4.7 is available
rubygem-sinatra-1.4.7 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygem-sinatra (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jun Aruga
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: 1344101
  Show dependency treegraph
 
Reported: 2016-01-24 19:17 EST by Upstream Release Monitoring
Modified: 2016-08-08 11:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-sinatra-1.4.7-1.fc25
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 11:15:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 1.4.7 (#1301419) (1.15 KB, patch)
2016-01-24 19:18 EST, Upstream Release Monitoring
no flags Details | Diff
Update to 1.4.7. Fix broken dependency. (5.99 KB, patch)
2016-08-01 16:35 EDT, Jun Aruga
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2016-01-24 19:17:58 EST
Latest upstream release: 1.4.7
Current version/release in rawhide: 1.4.6-2.fc23
URL: http://rubygems.org/gems/sinatra

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2016-01-24 19:18:15 EST
Created attachment 1117734 [details]
[patch] Update to 1.4.7 (#1301419)
Comment 2 Upstream Release Monitoring 2016-01-24 19:22:41 EST
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=12671947
Comment 3 Jun Aruga 2016-08-01 13:35:57 EDT
I will take this!
Comment 4 Jun Aruga 2016-08-01 16:35 EDT
Created attachment 1186535 [details]
Update to 1.4.7. Fix broken dependency.

Hi, I updated to latest version 1.4.7.
And I fixed broken dependency. The dependency was broken depended library "rubygem-rack" was updated to 2.0.1 for both master(rawhide) and f25.

If you update this patch to master and f25, you can fix it.
or I can push it by myself.

Could you review my patch?
Thanks.
Comment 5 Jun Aruga 2016-08-01 16:38:26 EDT
You must be receiving below mail.


```
Broken dependencies: rubygem-sinatra
rubygem-sinatra has broken dependencies in the rawhide tree:
On x86_64:
        1:rubygem-sinatra-1.4.6-3.fc24.noarch requires rubygem(rack) < 0:2
On i386:
        1:rubygem-sinatra-1.4.6-3.fc24.noarch requires rubygem(rack) < 0:2
On armhfp:
        1:rubygem-sinatra-1.4.6-3.fc24.noarch requires rubygem(rack) < 0:2
Please resolve this as soon as possible.
```
Comment 6 Vít Ondruch 2016-08-08 08:55:23 EDT
Is there some reason why you merge the patches into single file, instead of applying them one by one? I think that the later would be more readable ...
Comment 7 Jun Aruga 2016-08-08 09:35:27 EDT
(In reply to Vít Ondruch from comment #6)
> Is there some reason why you merge the patches into single file, instead of
> applying them one by one? I think that the later would be more readable ...

Yes, I have a reason to unify these commits to single patch file.

```
+# Patch for Rack 2.x.
+# https://github.com/sinatra/sinatra/commit/6aea9f8
+# https://github.com/sinatra/sinatra/commit/fad3619
+# https://github.com/sinatra/sinatra/commit/1a9642b
+# https://github.com/sinatra/sinatra/commit/1dfae3d
+Patch0: rubygem-sinatra-1.4.7-fix-for-rack-2.patch
```

I needed to fix conflict manually to create a patch for 1st commit (6aea9f8).
Then I created 2nd, 3rd and 4th patches based on 1st patched source code.

And all of these 4 commits is going to be included to next version's gem.
So, I thought a patch is better than 4 separated patch.

That is the reason.

Ref.
Below is my working branch for that. Latest 4 commits.
https://github.com/junaruga/sinatra/commits/feature/fix-for-rack2-based-on-v1.4.7


However I can also create 4 patches for you, if you like.
How do you think? Do you prefer 4 patches than single patch?
Comment 8 Vít Ondruch 2016-08-08 11:15:33 EDT
Thanks for explanation. It is suboptimal, but since it is hopefully just temporary measure, lets live with that => I build the updated package in F25+

Note You need to log in before you can comment on or make changes to this bug.