Bug 1301422 - UBUNTU installation - installation of ceph-test is failing
UBUNTU installation - installation of ceph-test is failing
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Installer (Show other bugs)
1.3.2
x86_64 Linux
unspecified Severity medium
: rc
: 1.3.2
Assigned To: Ken Dreyer (Red Hat)
ceph-qe-bugs
:
Depends On:
Blocks: 1263608
  Show dependency treegraph
 
Reported: 2016-01-24 19:19 EST by Rachana Patel
Modified: 2016-02-29 09:45 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.94.5-3redhat1trusty
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:45:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2016-01-24 19:19:55 EST
Description of problem:
=======================
On ubuntu, installation of ceph-test package is failing with error:-
The following packages have unmet dependencies:
 ceph-test : Depends: libradosstriper1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Version-Release number of selected component (if applicable):
=============================================================
ice-setup_0.4.5-1

How reproducible:
=================
always


Steps to Reproduce:
=====================
1. Install ubuntu 14.x -
2. kernel update to 3.19 
3. performed preinstallation steps and installed ceph on cluster
4. install ceph-test to verify bug #1263608.


Actual results:
===============
c1@magna048:~/ceph-config$ sudo apt-get install ceph-test
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ceph-test : Depends: libradosstriper1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Expected results:
==================
Package should be installed successfully.


Additional info:
Comment 4 Ken Dreyer (Red Hat) 2016-01-26 01:36:50 EST
I tried adding the following to the "install" target:

        # Drop ceph-test binaries that link to libradosstriper
        rm $(DESTDIR)/usr/bin/ceph_test_rados_striper_api_aio
        rm $(DESTDIR)/usr/bin/ceph_test_rados_striper_api_io
        rm $(DESTDIR)/usr/bin/ceph_test_rados_striper_api_striping

and this seems to have correctly removed the dependency on libradosstriper1.
Comment 7 Hemanth Kumar 2016-02-05 10:27:10 EST
ceph-test package is getting installed now.
http://pastebin.test.redhat.com/346590 :- execution steps

Moving to Verified
Comment 9 errata-xmlrpc 2016-02-29 09:45:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.