Bug 1301427 - [Director] Change parameters to parameter_defaults for NFS storage in OSP8 (not for OSP7)
[Director] Change parameters to parameter_defaults for NFS storage in OSP8 (n...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation, Reopened, Triaged, ZStream
Depends On: 1271266 1280012
Blocks: 1290377
  Show dependency treegraph
 
Reported: 2016-01-24 20:44 EST by Dan Macpherson
Modified: 2016-04-13 00:47 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1280012
Environment:
Last Closed: 2016-04-13 00:47:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jiri Stransky 2016-02-11 11:50:10 EST
*** Bug 1284988 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Stransky 2016-02-11 12:00:40 EST
The change from parameters to parameter_defaults should ideally happen for any reference or derivation of storage-environment.yaml, as that's what storage-environment.yaml has in stable/liberty branch:

https://github.com/openstack/tripleo-heat-templates/blob/b908fbac0ba821b47029782030c680f22cce653d/environments/storage-environment.yaml
Comment 4 Dan Macpherson 2016-02-11 20:43:15 EST
Hi Jiri,

Thanks for the confirmation on this. Will implement this for OSP 8.
Comment 6 Dan Macpherson 2016-02-12 02:43:35 EST
Changes to parameter_defaults for OSP 8 storage sections:

http://file.bne.redhat.com/~dmacpher/OpenStack/8.0/Director/#sect-Configuring_NFS_Storage

http://file.bne.redhat.com/~dmacpher/OpenStack/8.0/Director/#sect-Advanced-Configuring_Ceph_Storage

Jiri, how does it look to you? Any further changes required?
Comment 7 Jiri Stransky 2016-02-22 08:00:40 EST
Looks correct, thanks!
Comment 8 Dan Macpherson 2016-02-22 10:43:32 EST
This has been released publicly. Closing BZ.
Comment 9 Dan Macpherson 2016-02-22 10:45:05 EST
Ignore comment #8. This is for OSP 8, which hasn't been released.

Setting to VERIFIED.
Comment 10 Andrew Dahms 2016-04-13 00:47:18 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.