Bug 1301469 - validation required for lookup button in provisioning form
validation required for lookup button in provisioning form
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Matouš Mojžíš
ui:validation
: ZStream
Depends On:
Blocks: 1314780
  Show dependency treegraph
 
Reported: 2016-01-25 02:21 EST by Aziza Karol
Modified: 2016-06-29 11:32 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1314780 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:32:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
validation required (58.08 KB, image/png)
2016-01-25 02:21 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2016-01-25 02:21:03 EST
Created attachment 1117828 [details]
validation required

Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.1.20160114044944_395c086

How reproducible:
100%

Steps to Reproduce:
1.configure ldap
2.In provisioning virtual machine form just click on lookup button without entering any details. see attached screenshot
3.

Actual results:
when clicked on lookup button spinner just spins and no flash message is displayed.

Expected results:
validation message is required

Additional info:
Comment 2 Shveta 2016-01-27 14:43:29 EST
Assigning to add test case
Comment 5 CFME Bot 2016-03-03 17:06:04 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d12fc2ae54d7840f4e6edd528bc2001e3bc9fbaf

commit d12fc2ae54d7840f4e6edd528bc2001e3bc9fbaf
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Mar 3 15:44:25 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Mar 3 15:44:25 2016 -0500

    Turn off Lookup button when Email field is empty.
    
    Turn Lookup button on/off based upon entry in email field.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301469

 .../application_controller/miq_request_methods.rb     |  7 +++++++
 app/views/miq_request/_prov_field.html.haml           | 19 +++++++++++--------
 2 files changed, 18 insertions(+), 8 deletions(-)
Comment 6 CFME Bot 2016-03-04 15:45:13 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7d2f4c11f32ca17c89fedd2bfdc8d5337bc6330d

commit 7d2f4c11f32ca17c89fedd2bfdc8d5337bc6330d
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Mar 3 15:44:25 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Mar 4 13:09:52 2016 -0500

    Turn off Lookup button when Email field is empty.
    
    Turn Lookup button on/off based upon entry in email field.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301469
    https://bugzilla.redhat.com/show_bug.cgi?id=1314780
    (cherry picked from commit d12fc2a)

 .../application_controller/miq_request_methods.rb     |  7 +++++++
 app/views/miq_request/_prov_field.html.haml           | 19 +++++++++++--------
 2 files changed, 18 insertions(+), 8 deletions(-)
Comment 7 CFME Bot 2016-03-04 15:45:17 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f5fc7444b7ec895843a3b4efd575860e1479f13e

commit f5fc7444b7ec895843a3b4efd575860e1479f13e
Merge: 0800dce 7d2f4c1
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Mar 4 15:31:13 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Mar 4 15:31:13 2016 -0500

    Merge branch '55z_pr_7089' into '5.5.z'
    
    Turn off Lookup button when Email field is empty.
    
    Turn Lookup button on/off based upon entry in email field.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301469
    https://bugzilla.redhat.com/show_bug.cgi?id=1314780
    (cherry picked from commit d12fc2a)
    
    @dclarizi please review/merge, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/7089
    
    See merge request !836

 .../application_controller/miq_request_methods.rb     |  7 +++++++
 app/views/miq_request/_prov_field.html.haml           | 19 +++++++++++--------
 2 files changed, 18 insertions(+), 8 deletions(-)
Comment 8 Matouš Mojžíš 2016-04-25 14:44:51 EDT
Verified in 5.6.0.4-beta2.3.20160421172650_719e256.
Lookup button is gray and doesn't do anything, until required fields are fulfilled.
Comment 10 errata-xmlrpc 2016-06-29 11:32:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.