Bug 1301543 - [abrt] systemd: __read_nocancel(): systemd-journald killed by SIGABRT
[abrt] systemd: __read_nocancel(): systemd-journald killed by SIGABRT
Status: CLOSED DUPLICATE of bug 1300212
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:26215adbea2d4d2729a6f8af96e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 06:06 EST by Bill Gianopoulos
Modified: 2016-01-25 12:17 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 12:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.26 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: cgroup (259 bytes, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: core_backtrace (3.84 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: dso_list (1.27 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: environ (300 bytes, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: maps (8.93 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: mountinfo (3.55 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: open_fds (2.09 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: proc_pid_status (1.21 KB, text/plain)
2016-01-25 06:06 EST, Bill Gianopoulos
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-01-25 06:07 EST, Bill Gianopoulos
no flags Details

  None (edit)
Description Bill Gianopoulos 2016-01-25 06:06:43 EST
Version-Release number of selected component:
systemd-228-7.gite35a787.fc24

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-journald
crash_function: __read_nocancel
executable:     /usr/lib/systemd/systemd-journald
global_pid:     467
kernel:         4.5.0-0.rc0.git8.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __read_nocancel at ../sysdeps/unix/syscall-template.S:84
 #1 _IO_new_file_underflow at fileops.c:592
 #2 _IO_default_uflow at genops.c:413
 #3 _IO_getline_info at iogetline.c:60
 #4 _IO_getline at iogetline.c:34
 #5 _IO_fgets at iofgets.c:53
 #6 fgets at /usr/include/bits/stdio2.h:263
 #7 cg_pid_get_path.constprop.112 at src/basic/cgroup-util.c:836
 #8 cg_pid_get_path_shifted at src/basic/cgroup-util.c:1223
 #9 dispatch_message_real.lto_priv.266 at src/journal/journald-server.c:658

Potential duplicate: bug 1237069
Comment 1 Bill Gianopoulos 2016-01-25 06:06:49 EST
Created attachment 1117900 [details]
File: backtrace
Comment 2 Bill Gianopoulos 2016-01-25 06:06:50 EST
Created attachment 1117901 [details]
File: cgroup
Comment 3 Bill Gianopoulos 2016-01-25 06:06:51 EST
Created attachment 1117902 [details]
File: core_backtrace
Comment 4 Bill Gianopoulos 2016-01-25 06:06:52 EST
Created attachment 1117903 [details]
File: dso_list
Comment 5 Bill Gianopoulos 2016-01-25 06:06:53 EST
Created attachment 1117904 [details]
File: environ
Comment 6 Bill Gianopoulos 2016-01-25 06:06:54 EST
Created attachment 1117905 [details]
File: limits
Comment 7 Bill Gianopoulos 2016-01-25 06:06:55 EST
Created attachment 1117906 [details]
File: maps
Comment 8 Bill Gianopoulos 2016-01-25 06:06:56 EST
Created attachment 1117907 [details]
File: mountinfo
Comment 9 Bill Gianopoulos 2016-01-25 06:06:57 EST
Created attachment 1117908 [details]
File: namespaces
Comment 10 Bill Gianopoulos 2016-01-25 06:06:58 EST
Created attachment 1117909 [details]
File: open_fds
Comment 11 Bill Gianopoulos 2016-01-25 06:06:59 EST
Created attachment 1117910 [details]
File: proc_pid_status
Comment 12 Bill Gianopoulos 2016-01-25 06:07:00 EST
Created attachment 1117911 [details]
File: var_log_messages
Comment 13 Jan Synacek 2016-01-25 07:51:30 EST
Any idea what was happening with your computer's hard drive when the crash happened? Any heavy disk loads?
Comment 14 Bill Gianopoulos 2016-01-25 11:18:27 EST
(In reply to Jan Synacek from comment #13)
> Any idea what was happening with your computer's hard drive when the crash
> happened? Any heavy disk loads?

So, this has been happening for a week or so now on two of my laptops.  What is going on with the hard drive is it is external hard drive attached via USB, so slower than normal.  The laptops run fedora 23 on the internal drive and i have rawhide installed on the usb drive. I have 2 of these rawhide USB drives BTW and the results are the same with both.

I have a Lenovo All-in-one system and a Samsung Laptop neither of which seem affected by this issue.

However, I have an ASUS and an HP both of which have this problem so bad that I can't even get the system to be able to log in and do anything in graphical mode, in order to do anything I have to boot to the multi-user target and just use command line.  For most of these reports I was running a dnf upgrade.

I can attach the output of an lshw from all 4 of the systems if you think that would help.
Comment 15 Zbigniew Jędrzejewski-Szmek 2016-01-25 12:17:33 EST
It's enough info that it's a USB drive. Those are slow, and have high latetency too.

*** This bug has been marked as a duplicate of bug 1300212 ***

Note You need to log in before you can comment on or make changes to this bug.