Bug 1301576 - Anaconda unexpectedly shifts time
Anaconda unexpectedly shifts time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 1225479 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 07:29 EST by Pavel Holica
Modified: 2016-03-09 14:46 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-24.13.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 14:15:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (12.11 KB, application/octet-stream)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
ifcfg.log (2.55 KB, text/plain)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
packaging.log (665 bytes, text/plain)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
program.log (15.51 KB, text/plain)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
storage.log (32.68 KB, text/plain)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
storage.state (16.00 KB, application/octet-stream)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
syslog (60.10 KB, text/plain)
2016-01-25 07:35 EST, Pavel Holica
no flags Details
X.log (21.41 KB, text/plain)
2016-01-25 07:37 EST, Pavel Holica
no flags Details
video.ogv (4.16 MB, video/x-theora+ogg)
2016-01-25 08:18 EST, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2016-01-25 07:29:44 EST
Description of problem:
When running interactive installation (either offline installation using DVD or with repo=http://... on kernel command line), anaconda shifts time strangely after selecting language.
I was able to reproduce this on both VM (host RHEL-7.2) and physical system.

Version-Release number of selected component (if applicable):
Fedora 23 x86_64 Server

How reproducible:
always

Steps to Reproduce:
1. Boot Server installation from DVD
2. Observe time in tmux
3. Select czech or maybe some other language
4. Continue to hub

Actual results:
Time shifted 40 minutes in case of Prague

Expected results:
Only timezone is changed, no time shift happens

Additional info:
Attaching video taken during installation showing host time, GUI and running date in tmux.
I've observed same behaviour during offline installation (in such case, the time wasn't corrected upon entering "date and time" spoke).
Comment 1 Pavel Holica 2016-01-25 07:35:00 EST
Created attachment 1117968 [details]
anaconda.log
Comment 2 Pavel Holica 2016-01-25 07:35:03 EST
Created attachment 1117969 [details]
ifcfg.log
Comment 3 Pavel Holica 2016-01-25 07:35:06 EST
Created attachment 1117970 [details]
packaging.log
Comment 4 Pavel Holica 2016-01-25 07:35:08 EST
Created attachment 1117971 [details]
program.log
Comment 5 Pavel Holica 2016-01-25 07:35:12 EST
Created attachment 1117972 [details]
storage.log
Comment 6 Pavel Holica 2016-01-25 07:35:16 EST
Created attachment 1117973 [details]
storage.state
Comment 7 Pavel Holica 2016-01-25 07:35:19 EST
Created attachment 1117974 [details]
syslog
Comment 8 Pavel Holica 2016-01-25 07:37:26 EST
Created attachment 1117976 [details]
X.log
Comment 9 Pavel Holica 2016-01-25 08:18 EST
Created attachment 1117986 [details]
video.ogv

Attaching forgotten video (bugzilla didn't allow to upload it due it's size).
Comment 10 David Shea 2016-03-09 14:15:30 EST
This should be fixed by b3096e797a3b76862f94662a865c6a83854f45c4
Comment 11 David Shea 2016-03-09 14:46:52 EST
*** Bug 1225479 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.