Bug 1301586 - ipa host-del --updatedns should remove related dns entries.
ipa host-del --updatedns should remove related dns entries.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 07:55 EST by German Parente
Modified: 2016-11-10 13:56 EST (History)
7 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:50:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description German Parente 2016-01-25 07:55:09 EST
Description of problem:

using the command 

"ipa host-del <client machine> --updatedns" is not deleting completely the dns entries.

For instance, this entry remains:

dn: idnsName=ipaclient,idnsname=example.com.,cn=dns,dc=example,dc=com

The entry is modified with "--updatedns":

======================================
time: 20160125074150
dn: idnsName=ipaclient,idnsname=example.com.,cn=dns,dc=example,dc=com
changetype: modify
delete: aAAARecord
-
replace: modifiersname
modifiersname: uid=admin,cn=users,cn=accounts,dc=example,dc=com
-
======================================

and

=======================================
time: 20160125074150
dn: idnsname=example.com.,cn=dns,dc=example,dc=com
changetype: modify
replace: idnsSOAserial
idnsSOAserial: 1453725712
-
replace: modifiersname
modifiersname: krbprincipalname=dns/ipaserver.example.com@example.com,cn=servi
 ces,cn=accounts,dc=example,dc=com
-
=======================================

but it's not clear to me yet why the entry is not completely deleted.

Feel free to close this bug if you think it's irrelevant.

Version-Release number of selected component (if applicable):

ipa-server-4.2.0-15.el7_2.3.x86_64


How reproducible: always


Additional info:

workaround: 

ipa dnsrecord-del example.com. ipaclient

which will finish to do:

======================================
time: 20160125075333
dn: idnsname=ipaclient,idnsname=example.com.,cn=dns,dc=example,dc=com
changetype: delete
modifiersname: uid=admin,cn=users,cn=accounts,dc=example,dc=com
=======================================
Comment 2 Petr Vobornik 2016-01-25 11:40:13 EST
German, could you paste here content of  idnsName=ipaclient,idnsname=example.com.,cn=dns,dc=example,dc=com after the mod operation which removed the AAAA record?
Comment 4 Petr Vobornik 2016-02-15 14:40:19 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5675
Comment 6 Petr Vobornik 2016-03-30 09:53:15 EDT
Summary of internal discussion
"""
So can we summarize and agree that:
a) It is a good idea to have an option to clean DNS record on the host-del
b) Since there are already expectations about system behavior this
option would not be enabled by default.
"""
Comment 9 Scott Poore 2016-09-09 17:56:29 EDT
Verified.

Version ::

ipa-server-4.4.0-9.el7.x86_64

Results ::

[root@master ~]# ipa host-add myhost.ipa.test --ip-address=192.168.122.99 
----------------------------
Added host "myhost.ipa.test"
----------------------------
  Host name: myhost.ipa.test
  Principal name: host/myhost.ipa.test@IPA.TEST
  Principal alias: host/myhost.ipa.test@IPA.TEST
  Password: False
  Keytab: False
  Managed by: myhost.ipa.test

[root@master ~]# ldapsearch -xLLL -D "cn=Directory Manager" -w Secret123 -b idnsname=myhost,idnsname=ipa.test.,cn=dns,dc=ipa,dc=test
dn: idnsname=myhost,idnsname=ipa.test.,cn=dns,dc=ipa,dc=test
objectClass: top
objectClass: idnsrecord
aRecord: 192.168.122.99
idnsName: myhost

[root@master ~]# ipa host-del --updatedns myhost.ipa.test
------------------------------
Deleted host "myhost.ipa.test"
------------------------------

[root@master ~]# ldapsearch -xLLL -D "cn=Directory Manager" -w Secret123 -b idnsname=myhost,idnsname=ipa.test.,cn=dns,dc=ipa,dc=test
No such object (32)

Matched DN: idnsname=ipa.test.,cn=dns,dc=ipa,dc=test
[root@master ~]# echo $?
32
Comment 11 errata-xmlrpc 2016-11-04 01:50:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.