Bug 1301588 - Configuring the RHQ Storage node running as Windows service cannot be done using rhq-storage-wrapper files
Configuring the RHQ Storage node running as Windows service cannot be done us...
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Storage Node (Show other bugs)
JON 3.3.4
Unspecified Unspecified
high Severity high
: ER01
: JON 3.3.6
Assigned To: Michael Burman
Mike Foley
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 07:57 EST by bkramer
Modified: 2016-07-07 10:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 10:27:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2016-01-25 07:57:05 EST
Description of problem:
Storage node windows service cannot be configured using rhq-storage-wrapper files (rhq-storage-wrapper.env, rhq-storage-wrapper.conf and rhq-storage-wrapper.inc). Files rhq-storage-wrapper.env and rhq-storage-wrapper.conf state that those files shouldn't be changed but that any change should be added in rhq-storage-wrapper.inc file. However, this does not seem to work.

Version-Release number of selected component (if applicable):
JBoss ON 3.3.0 (couldn't test on JBoss ON 3.3.4 due to Bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1301575)

How reproducible:
Always

Steps to Reproduce:
1. Stop RHQ Server service;
2. Stop RHQ Storage node service;
3. Navigate to $JON_SERVER_HOME\bin\wrapper and open rhq-storage-wrapper.inc file;
4. Add:
  
wrapper.java.additional.21="heap_min=-Xms2048M"
wrapper.java.additional.22="heap_max=-Xmx2048M"

and save the file.

4. Start Storage node service;
5. Start RHQ Server service;
6. Navigate to JBoss ON UI -> Administration -> Storage Nodes page and click on storage node link;


Actual results:
Heap Size value is not changed in "Storage Node Specific Settings" section

Expected results:
Heap Size value is changed in "Storage Node Specific Settings" section


Additional info:
Due to the bug reported in https://bugzilla.redhat.com/show_bug.cgi?id=1299448, currently it is not possible to change heap values using JBoss ON UI. The only way to change storage node's heap settings is to edit $JON_SERVER_HOME\rhq-storage\conf\cassandra-jvm.properties file.
Comment 1 Filip Brychta 2016-02-04 07:55:09 EST
It seems that additional properties in rhq-storage-wrapper.inc are totally ignored. Another way how to set heap is in rhq-storage-wrapper.env. However it's actually changed (visible in process cmdline parameters) it's not changed in UI.
Comment 2 Josejulio Martínez 2016-05-16 12:48:03 EDT
"rhq-storage-wrapper.conf" recommends to avoid customize that file, instead use "rhq-storage-wrapper.inc" and "rhq-storage-wrapper.env".

However, "rhq-storage-wrapper.env" says:

  #*****************************************************************************
  # MANAGED SETTINGS
  #
  # This section represents the values managed as RHQ Storage Node resource
  # configuration values.  Or, set by the installer.
  #
  # DO NOT EDIT THESE VALUES BY HAND.  Changes should be performed via
  # the Administration section of the RHQ GUI.
  #
  #*****************************************************************************
  ...
  set.heap_min=-Xms512M
  set.heap_max=-Xms512M
  ...

So we shouldn't mess with those values, is not intended to work in that way.
At this point, Bug 1299448 has been fixed, I vote to use that one instead.

Note You need to log in before you can comment on or make changes to this bug.