Bug 1301611 - rhnreg_ks ISE + traceback
rhnreg_ks ISE + traceback
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2016-01-25 09:06 EST by Lukáš Hellebrandt
Modified: 2017-09-28 14:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-schema-2.5.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 04:02:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (8.29 KB, text/plain)
2016-01-25 09:07 EST, Lukáš Hellebrandt
no flags Details

  None (edit)
Description Lukáš Hellebrandt 2016-01-25 09:06:44 EST
Description of problem:
When registering with rhnreg_ks on certain systems, rhnreg_ks outputs ISE and there is traceback in server's error_log.

Version-Release number of selected component (if applicable):
RHEL
Oracle
(Seems to be specific for Spacewalks on RHEL (both 6 and 7) with Oracle backend, I am not sure though).
Packages on testing machine:
spacewalk-backend-2.5.13-1
spacewalk-java-2.5.38-1

How reproducible:
Always when registering to the affected server

Steps to Reproduce:
1. Have a SW, synced and with AK as needed
2. On client, # rhnreg_ks --force --activationkey=<ak> --profilename=<name>

Actual results:

- Client:
rhn-plugin: Error communicating with server. The message was:
Internal Server Error

- Server:
Traceback in /var/log/httpd/error_log (attached)

Expected results:
System registers
Comment 1 Lukáš Hellebrandt 2016-01-25 09:07 EST
Created attachment 1118053 [details]
traceback
Comment 3 Tomas Lestach 2016-01-25 11:41:55 EST
Looking at the error message:
 'ORA-20236: (channel_subscribe_no_family) - Attempt to subscribe to a channel with no family'
what channel is your activation key associated with? How did you create the channel?
Comment 4 Lukáš Hellebrandt 2016-01-26 05:22:26 EST
It happens for both RHEL6 channel synced from dump and a custom channel.
Comment 5 Jan Dobes 2016-01-29 12:45:50 EST
fixed in spacewalk master:

b507db5d3c499201a65c6736a402a026b09239b2
Comment 6 Tomáš Kašpárek 2016-06-16 04:02:33 EDT
Spacewalk 2.5 was released.
Comment 7 Eric Herget 2017-09-28 14:08:05 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.