Bug 1301612 - Nautilus stopped recognizing "nfs://" URLs
Nautilus stopped recognizing "nfs://" URLs
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 09:08 EST by Kanwar Ranbir Sandhu
Modified: 2016-07-19 14:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:40:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kanwar Ranbir Sandhu 2016-01-25 09:08:49 EST
Description of problem:
I can no longer browse nfs shares from Nautilus. If I type in a NFS URL, Nautilus immediately says the URL is not recognized. All of my NFS bookmarks stopped working, too.

Version-Release number of selected component (if applicable):
nautilus-3.16.3-1.fc22.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Open Nautilus.
2. Click "Connect to Server" icon located in the left pane.
3. In the "Connect to Server" window's "Server Address" text box, type "nfs://".

Actual results:
Nautilus reports "This file server type is not recognized."

Expected results:
Nautilus connects to the NFS server and opens the share in the Nautilus browser window.

Additional info:
Browsing NFS shares worked before. My system is update so the only thing I can gather is that an update broke it. 

The NFS server has not had any configuration changes. I can still manually mount (i.e. from a terminal) the NFS exports and use them as before.
Comment 1 Kanwar Ranbir Sandhu 2016-01-26 08:58:03 EST
This ticket can be closed. I've figured out what was wrong and now I've realized "nfs://" hasn't worked in Nautilus for a while. 

My Nautilus bookmarks were actually bookmarks for the automount locations and it was autofs (configured in freeipa) that was the underlying problem. Restarting the sssd service fixed that: the bookmarks are working now because autofs is working again.

Sorry for the noise!
Comment 2 Fedora End Of Life 2016-07-19 14:40:47 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.