This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1301614 - (CVE-2014-9762, CVE-2014-9763, CVE-2014-9764) CVE-2014-9762 imlib2: security issues fixed in 1.4.7
CVE-2014-9762 imlib2: security issues fixed in 1.4.7
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20160120,repor...
: Security
Depends On: 1301616 1301617 1301615
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 09:18 EST by Andrej Nemec
Modified: 2016-02-10 05:51 EST (History)
4 users (show)

See Also:
Fixed In Version: imlib2 1.4.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Nemec 2016-01-25 09:18:20 EST
Multiple security issues were addressed in the imlib2-1.4.7 version.


Original bug report:

http://seclists.org/oss-sec/2016/q1/162

CVE assignment:

http://seclists.org/oss-sec/2016/q1/182

Upstream git patches:

CVE-2014-9762, segmentation fault on images without colormap:

https://git.enlightenment.org/legacy/imlib2.git/commit/?h=v1.4.7&id=39641e74a560982fbf93f29bf96b37d27803cb56

CVE-2014-9763, divison-by-zero crash:

https://git.enlightenment.org/legacy/imlib2.git/commit/?h=v1.4.7&id=c21beaf1780cf3ca291735ae7d58a3dde63277a2

CVE-2014-9764, segmentation fault when opening specifically crafted input:

https://git.enlightenment.org/legacy/imlib2.git/commit/?h=v1.4.7&id=1f9b0b32728803a1578e658cd0955df773e34f49
Comment 1 Andrej Nemec 2016-01-25 09:18:55 EST
Created imlib2 tracking bugs for this issue:

Affects: fedora-all [bug 1301615]
Affects: epel-6 [bug 1301616]
Affects: epel-7 [bug 1301617]
Comment 2 Tomas Smetana 2016-01-25 11:21:18 EST
There is no ABI incompatibility between 1.4.6 and 1.4.7 so it should be OK to rebase.
Comment 3 Fedora Update System 2016-01-30 13:20:42 EST
imlib2-1.4.7-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2016-02-10 05:51:31 EST
imlib2-1.4.7-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.