Bug 1301629 - Deployment of Ceph times out in IPv6
Deployment of Ceph times out in IPv6
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
x86_64 Linux
high Severity high
: z4
: 7.0 (Kilo)
Assigned To: Giulio Fidente
Marius Cornea
: ZStream
: 1301627 (view as bug list)
Depends On:
Blocks: 1302593 1309822
  Show dependency treegraph
 
Reported: 2016-01-25 09:44 EST by Giulio Fidente
Modified: 2016-04-26 20:08 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-46.el7ost.noarch
Doc Type: Bug Fix
Doc Text:
Previously, Ceph was inappropriately configured when using IPv6. As a result, the setup of Ceph in the overcloud failed, causing the deployment to timeout, if the storage network used IPv6 addresses. With this update, the relevant Ceph configuration option, 'ms_bind_ipv6', based on the 'CephIPv6' parameter is now used. As a result, Ceph is functional and the overcloud deployment is completed when using IPv6 for the storage network if the appropriate input parameters are provided to the Orchestration service.
Story Points: ---
Clone Of: 1299613
Environment:
Last Closed: 2016-02-18 11:44:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 272068 None None None 2016-01-25 09:45 EST

  None (edit)
Description Giulio Fidente 2016-01-25 09:44:10 EST
+++ This bug was initially created as a clone of Bug #1299613 +++

rhel-osp-director:  Scale-up Ceph from 1 to 3 fails, when Overcloud is deployed with SSL (resources.EndpointMap: Timed out) .


Environment (backport-job 7.3):
------------------------------
instack-0.0.7-2.el7ost.noarch
instack-undercloud-2.1.2-37.el7ost.noarch
python-rdomanager-oscplugin-0.0.10-25.el7ost.noarch
python-heatclient-0.6.0-1.el7ost.noarch
openstack-heat-api-2015.1.2-6.el7ost.noarch
heat-cfntools-1.2.8-2.el7.noarch
openstack-heat-common-2015.1.2-6.el7ost.noarch
openstack-heat-engine-2015.1.2-6.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-103.el7ost.noarch
openstack-heat-templates-0-0.8.20150605git.el7ost.noarch
openstack-heat-api-cloudwatch-2015.1.2-6.el7ost.noarch
openstack-heat-api-cfn-2015.1.2-6.el7ost.noarch


Steps:
-------
(1) Deploy overcloud with SSL with 1 Ceph node.
(2) Attempt to Scale-up Ceph from 1 to 3 node 

Results :
---------
Stack Update failed - due to resources.EndpointMap: Timed out .
Comment 1 Giulio Fidente 2016-01-25 10:12:40 EST
*** Bug 1301627 has been marked as a duplicate of this bug. ***
Comment 5 Marius Cornea 2016-02-16 11:09:34 EST
[root@overcloud-controller-0 ~]# rpm -qa | grep puppet-modules
openstack-puppet-modules-2015.1.8-51.el7ost.noarch

[root@overcloud-controller-0 ~]# grep ms_bind /etc/ceph/ceph.conf 
ms_bind_ipv6 = True
Comment 7 errata-xmlrpc 2016-02-18 11:44:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0265.html

Note You need to log in before you can comment on or make changes to this bug.