Bug 1301667 - Tor does not start [NEEDINFO]
Summary: Tor does not start
Status: CLOSED DUPLICATE of bug 1375369
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tor
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jamie Nguyen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-25 16:09 UTC by Răzvan Sandu
Modified: 2019-01-07 23:37 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-07 23:37:51 UTC
jamielinux: needinfo? (razvan.sandu)


Attachments (Terms of Use)

Description Răzvan Sandu 2016-01-25 16:09:50 UTC
Description of problem:

As of January 2016, the tor package in Fedora EPEL is broken (can be installed, but cannot be run/service started, at least in Centos 7.x). However,an already built tor RPM package do exist in official tor repo, as stated at in section "Name clash warning" here: https://www.torproject.org/docs/rpms.html.en 

Version-Release number of selected component (if applicable):
tor-0.2.7.6-5.el7.x86_64 (from EPEL)
tor-0.2.7.6-tor.1.rh6_7.x86_64 (from the Tor repository)

How reproducible:
Always

Steps to Reproduce:
1. Fresh install CentOS 7 1511 (x86_64) 
2. Install epel-release package
3. Install tor package from EPEL
4. Try to configure and start tor service (for a relay)
5. Note that with tor package from EPEL, tor service won't start
6. Uninstall tor package (EPEL version)
7. Install tor repo as described at https://www.torproject.org/docs/rpms.html.en
8. Manually exclude EPEL's tor package from installing (as described in "Name clash warning" above)
9  Install tor package from official tor repo
10. With identical configuration (same /etc/tor/torrc as that at point 4), tor service will now start.

Actual results:
With EPEL package, tor service won't start. With original tor RPM package, tor will start.

Expected results:
Present tor package in EPEL should be replaced with the working one.

Additional info:

Comment 1 Jamie Nguyen 2016-01-25 17:48:23 UTC
Will need more information than "is broken".

What error do you receive?
Please post output of: journalctl _SYSTEMD_UNIT=tor.service
What are the contents of your /etc/tor/torrc?
Please post output of: ls -la /var/lib/tor

Comment 2 Marcel Haerry 2017-06-29 16:39:40 UTC
Given multiple ppl are successfully running tor using the EPEL package, I can only assume, that the torrc in question is trying to setup an onion servcie (as noted in #1375369) and hence fails.

But otherwise I would suggest to close that bug.

Comment 3 Marcel Haerry 2019-01-07 23:37:51 UTC

*** This bug has been marked as a duplicate of bug 1375369 ***


Note You need to log in before you can comment on or make changes to this bug.