Bug 130169 - up2dates fails to update itself via actions
up2dates fails to update itself via actions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 156852 (view as bug list)
Depends On:
Blocks: 120698 up2date-rhel3-u3
  Show dependency treegraph
 
Reported: 2004-08-17 13:45 EDT by Adrian Likins
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:07:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2004-08-17 13:45:35 EDT
This is a workaround for a bug in up2date-4.2.16 (version
   included in Update 3 for RHEL 3). That version fails to
  update the up2date package when scheduled from the website
  (commandline or gui useage is fine). In order to enable
  customers to update "up2date" via the RHN web interface,
  this package requires a up2date >= 4.2.33. User can
  choose to install this package, and the newer up2date
  will be installed as a dependency. The new up2date
  will be correct, and the "up2date-update" package can
  then be removed.


Test plan:

Put the new up2date (4.2.36 or higher) into a channel
(child channel is fine)

Install up2date-4.2.16 on a rhel3 box.

attempt to update to newest update via an action
that schedules up2date only. This will fail.

Then try to install the "up2date-update" package.
This will schedule an action for "up2date-update" that
should pull in the newer up2date as a dep. 

Then do basic sanity checks on up2date. 

Then we need to push an even newer up2date package
into the channel. Then we need to verify that
up2date-4.2.36 can be updated to 4.2.36.1 (for example)
via a "update" action on just the up2date package. 

Then downgrade to up2date-4.2.36, then update 
up2date manually "aka, up2date up2date". 

Repeat, but this time with "up2date -u".

Repeat but this time with the gui.
Comment 1 Adrian Likins 2004-08-18 12:38:19 EDT
see /mnt/redhat/beehive/comps/dist/3.0E-scratch/up2date/4.2.36.1-1
for version to verify that 4.2.36 can update itself. 
Comment 2 Fanny Augustin 2004-08-18 16:55:15 EDT
Looks beautiful ;-)  
Comment 3 Todd Warner 2004-08-26 19:17:30 EDT
See also bug 130867
Comment 4 John Flanagan 2004-09-02 01:07:17 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-427.html
Comment 5 Clifford Perry 2005-05-11 06:50:30 EDT
*** Bug 156852 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.