Bug 1301726 - margins on printed documents are too small
margins on printed documents are too small
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gedit (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 15:36 EST by Matěj Cepl
Modified: 2016-11-04 02:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: gedit-3.14.3-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:19:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from the upstream bug (4.55 KB, patch)
2016-01-25 15:38 EST, Matěj Cepl
no flags Details | Diff
patch from the upstream bug (893 bytes, patch)
2016-01-25 15:39 EST, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 572741 None None None 2016-01-25 15:36 EST
Launchpad 331077 None None None 2016-01-25 15:36 EST
Red Hat Product Errata RHBA-2016:2424 normal SHIPPED_LIVE gedit bug fix update 2016-11-03 09:59:33 EDT

  None (edit)
Description Matěj Cepl 2016-01-25 15:36:08 EST
Description of problem:
In gedit 2.24.2 (Ubuntu 8.10), the margins of a printed document does not seems to be configurable. The left margin is very small - about 1 cm.

While such small margins maximizes the printable text on a page, the left margin is too small to punch holes in the sheet using a paper hole punch - holes are punched in the text.

See attached file, a print-out of the "Thin clients" Wikipedia page, copied from a Web browser and pasted in gedit for printing. Having configurable margins could enable the user to avoid such problems.

Version-Release number of selected component (if applicable):
gedit-3.14.3-9.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. print a text file with gedit
2. too small margins on printout
3.

Actual results:
see attached PDF

Expected results:
something like 1" margins (or 65 chars / line)
Comment 1 Matěj Cepl 2016-01-25 15:38 EST
Created attachment 1118200 [details]
patch from the upstream bug
Comment 2 Matěj Cepl 2016-01-25 15:39 EST
Created attachment 1118201 [details]
patch from the upstream bug
Comment 4 Matthias Clasen 2016-01-28 09:39:18 EST
thanks for the patch
Comment 8 errata-xmlrpc 2016-11-04 02:19:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2424.html

Note You need to log in before you can comment on or make changes to this bug.