Bug 1301738 - [RFE] When deploying SSL enabled overcloud non-https requests to Horizon should redirect to https
Summary: [RFE] When deploying SSL enabled overcloud non-https requests to Horizon shou...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Rodrigo Duarte
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-25 21:16 UTC by Marius Cornea
Modified: 2016-12-14 15:21 UTC (History)
13 users (show)

Fixed In Version: puppet-tripleo-5.2.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:21:23 UTC
scohen: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 294456 None None None 2016-03-21 08:26:08 UTC

Description Marius Cornea 2016-01-25 21:16:04 UTC
Description of problem:
When deploying SSL enabled overcloud non-https requests should redirect to https. Currently when accessing non-https on port 80 you get a connection refused message.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-112.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy SSL enabled overcloud

Actual results:
curl -I https://rxtx.ro
HTTP/1.1 301 Moved Permanently
Date: Mon, 25 Jan 2016 21:12:12 GMT
Server: Apache/2.4.6 (Red Hat Enterprise Linux)
Location: https://rxtx.ro/dashboard
Content-Type: text/html; charset=iso-8859-1
Set-Cookie: SERVERID=; Expires=Thu, 01-Jan-1970 00:00:01 GMT; path=/
Cache-control: private

curl -I http://rxtx.ro
curl: (7) Failed to connect to rxtx.ro port 80: Connection refused

Expected results:
non-https redirects to https

Comment 2 Mike Burns 2016-04-07 21:07:13 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 9 errata-xmlrpc 2016-12-14 15:21:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.