Bug 1301760 - DBusActivatable flag interferes with jumplist actions
DBusActivatable flag interferes with jumplist actions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gedit (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 17:56 EST by Matěj Cepl
Modified: 2016-11-04 02:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: gedit-3.14.3-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:19:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from the upstream bug (12.32 KB, patch)
2016-01-25 17:56 EST, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 744184 None None None 2016-01-25 17:56 EST

  None (edit)
Description Matěj Cepl 2016-01-25 17:56:49 EST
Created attachment 1118264 [details]
patch from the upstream bug

Description of problem:
Gedit on a standard Fedora 21 install comes with two jumplist actions: "Open a New Window" and "Open a New Document". Neither of those work out of the box.

The problem seems to be caused by the "DBusActivatable=True" line in the org.gnome.gedit desktop file. Removing that line restores the functionality of the additional actions.

(see the upstream bug for more details; it turned out to be more complicated than two lines in .desktop file, see the attached patch)

Version-Release number of selected component (if applicable):
gedit-3.14.3-9.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.start gedit
2.right click its icon in the jump list and select either of the two actions
3.

Actual results:
no response

Expected results:
it should happen

Additional info:
Comment 1 Matthias Clasen 2016-01-28 09:40:02 EST
thanks for the patch
Comment 5 errata-xmlrpc 2016-11-04 02:19:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2424.html

Note You need to log in before you can comment on or make changes to this bug.