Bug 1301761 - Spell Checker: 'highlight misspelled words' metadata is not saved with the file.
Spell Checker: 'highlight misspelled words' metadata is not saved with the file.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gedit (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 18:05 EST by Matěj Cepl
Modified: 2016-11-04 02:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: gedit-3.14.3-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:19:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from the upstream bug (763 bytes, patch)
2016-01-25 18:05 EST, Matěj Cepl
no flags Details | Diff
patch from the upstream bug (4.04 KB, patch)
2016-01-25 18:06 EST, Matěj Cepl
no flags Details | Diff
patch from the upstream bug (1.32 KB, patch)
2016-01-25 18:13 EST, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 741853 None None None 2016-01-25 18:05 EST

  None (edit)
Description Matěj Cepl 2016-01-25 18:05:42 EST
Created attachment 1118266 [details]
patch from the upstream bug

Description of problem:
I don't want the 'highlight misspelled words' setting enabled, so I disable it but the next time that I open the file it is sometimes enabled again.

Steps to reproduce:
- Have two files (*.m with Matlab highlighting in my case), open them in gedit, disable the 'highlight misspelled words' setting if set.
- Close gedit
- Reopen the two files from the command line, e.g. 'gedit *.m'.

Result:
For the first file the setting is still disabled, but for the second file the setting is enabled.

The same goes in the other direction as well ... when I actually want for some document to have spelling enabled, it is not saved to the gvfs metadata either. Actually, gvfs-file doesn't show any gedit metadata at all.

When opening the files one by one from the gedit UI, the bug doesn't occur, the setting is correctly disabled.

Version-Release number of selected component (if applicable):
gedit-3.14.3-9.el7.x86_64

How reproducible:
100%
Comment 1 Matěj Cepl 2016-01-25 18:06 EST
Created attachment 1118267 [details]
patch from the upstream bug
Comment 2 Matěj Cepl 2016-01-25 18:13 EST
Created attachment 1118268 [details]
patch from the upstream bug
Comment 3 Matthias Clasen 2016-01-28 09:35:52 EST
thanks for the patch
Comment 7 errata-xmlrpc 2016-11-04 02:19:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2424.html

Note You need to log in before you can comment on or make changes to this bug.