Bug 1301764 - fix generation of desktop files for external tools
fix generation of desktop files for external tools
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gedit (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-25 18:17 EST by Matěj Cepl
Modified: 2016-11-04 02:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: gedit-3.14.3-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:19:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from the upstream bug (1.26 KB, patch)
2016-01-25 18:17 EST, Matěj Cepl
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 605826 None None None 2016-01-25 18:17 EST

  None (edit)
Description Matěj Cepl 2016-01-25 18:17:56 EST
Created attachment 1118269 [details]
patch from the upstream bug

Description of problem:

From the commit log:

The .desktop files were not generated since there were two rules for the
same targets. So the last rule was executed, which is the mkdir command.

To be sure that the mkdir command is executed before any target is
built, we can use $(shell ...). See:
http://stackoverflow.com/questions/2122602/force-makefile-to-execute-script-before-building-targets

Version-Release number of selected component (if applicable):
gedit-3.14.3-9.el7.x86_64
Comment 2 Matthias Clasen 2016-01-28 09:34:27 EST
thanks for the patch
Comment 5 Matěj Cepl 2016-08-30 14:43:13 EDT
Patch has been included.
Comment 7 errata-xmlrpc 2016-11-04 02:19:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2424.html

Note You need to log in before you can comment on or make changes to this bug.