Bug 1301841 - The password is not cleared after unchecking "Save this password in your keyring"
The password is not cleared after unchecking "Save this password in your keyr...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.8
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 02:04 EST by xiaodwan
Modified: 2017-03-21 06:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: virt-manager-0.9.0-32.el6
Doc Type: Bug Fix
Doc Text:
Cause: setup VM with password protected vnc/spice and save the password for next use Consequence: when user opens VM console and unset "Save this password in your keyring" the password remains saved Fix: code to forget the password was missing so it had to be implemented Result: now if user unset "Save this password in your keyring" the next time when he's asked for password the text field is empty
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 06:41:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaodwan 2016-01-26 02:04:52 EST
Description of problem:
The password is not cleared after unchecking "Save this password in your keyring".

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-31.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. launch "virt-manager"
2. Open hardware details and click "display spice" device and Set a password for it.
3. Start the guest.
4. Check the "Save this password in your keyring" option and type the password.
5. Close the vm window and double click the vm to open the vm window again, check the password is remembered.
6. Uncheck the "Save this password in your keyring" option and click login.
7. Close the vm window and double click the vm to open the vm window again.



Actual results:
The password is remembered and the "Save this password in your keyring" option is still checked.

Expected results:
The password should be cleared and the "Save this password in your keyring" option should be unchecked.

Additional info:
1. It's better to only save the password when login success, now it saves every password no matter what the password is.
Comment 5 zhoujunqin 2016-12-05 04:29:21 EST
I can reproduce this issue with package:
virt-manager-0.9.0-31.el6.x86_64

Then try to verify with new build:
virt-manager-0.9.0-33.el6.x86_64

Steps:
1. launch "virt-manager"
2. Open hardware details and click "display spice" device and Set a password for it.
3. Start the guest.
4. Check the "Save this password in your keyring" option and type the password.
5. Close the vm window and double click the vm to open the vm window again, check the password is remembered.
6. Uncheck the "Save this password in your keyring" option and click login.
7. Close the vm window and double click the vm to open the vm window again.

Result:
The password is cleared and the "Save this password in your keyring" option is unchecked.
And also repeat step4-7, no error find, so move this bug from ON_QA to VERIFIED.
Comment 7 errata-xmlrpc 2017-03-21 06:41:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0686.html

Note You need to log in before you can comment on or make changes to this bug.