Bug 1301860 - vCPU offline hang in real-time guest
vCPU offline hang in real-time guest
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Xu
Pei Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 03:22 EST by Peter Xu
Modified: 2017-10-11 00:42 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-11 00:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Daniel Bristot de Oliveira 2016-02-03 14:34:47 EST
Hi Peter,

There are some known hotplug issues on kernel-rt. For an example, see BZ1267425.

On this BZ I was able to identify the root cause by inspecting a
vmcore, and on these cases, the vmcore is the best tool to understand
why the system hanged.

Can you please capture a vmcore of the VM after it hangs on hotplug
operations?

Here is a document from support explaining how to capture a vmcore of a VM:

https://access.redhat.com/solutions/39604

We will also need the debuginfo packages of the kernel that was running
on the VM.
Comment 6 Pei Zhang 2017-10-11 00:04:13 EDT
Peter, this issue has gone with rhel7.5. 


After online/offline 100 times using script in Description, both host and guest work well, not any error.

Versions:
3.10.0-730.rt56.658.el7.x86_64
qemu-kvm-rhev-2.10.0-1.el7.x86_64
libvirt-3.7.0-2.el7.x86_64
tuned-2.8.0-5.el7.noarch


Best Regards,
Pei
Comment 7 Peter Xu 2017-10-11 00:42:46 EDT
(In reply to Pei Zhang from comment #6)
> Peter, this issue has gone with rhel7.5. 
> 
> 
> After online/offline 100 times using script in Description, both host and
> guest work well, not any error.
> 
> Versions:
> 3.10.0-730.rt56.658.el7.x86_64
> qemu-kvm-rhev-2.10.0-1.el7.x86_64
> libvirt-3.7.0-2.el7.x86_64
> tuned-2.8.0-5.el7.noarch
> 
> 
> Best Regards,
> Pei

Thanks Pei!  Then I'm closing the bug.

Peter

Note You need to log in before you can comment on or make changes to this bug.