Bug 1301912 - Bind starts before all network interfaces are up during boot
Bind starts before all network interfaces are up during boot
Status: CLOSED DUPLICATE of bug 1294506
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tomáš Hozza
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 06:16 EST by John Cameron
Modified: 2016-05-10 04:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 04:16:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cameron 2016-01-26 06:16:26 EST
Description of problem:
  Bind starts before all network interfaces are up during boot,
  Therefore only binds to the interfaces that are already up at the time.
  Particularly when using multiple VLAN interfaces which are
  Brought up one after the other.
Version-Release number of selected component (if applicable):
  bind-chroot-9.9.4-29.el7_2.1.x86_64
How reproducible:
  Always, depending on the amount of interfaces.
Steps to Reproduce:
 Install and configure bind-chroot
 Configure multiple VLAN interfaces with subnets from 10.1.1.1/24 to 10.1.1.10/24
 Reboot
Actual results:
  ss -tnl | grep -w 53
  LISTEN     0      10     127.0.0.1:53                       *:*
Expected results:
  ss -tnl | grep -w 53
  LISTEN     0      10     127.0.0.1:53                       *:*
  LISTEN     0      10     10.1.1.1:53                         *:*
  LISTEN     0      10     10.1.1.2:53                         *:*
  LISTEN     0      10     10.1.1.3:53                         *:*
  LISTEN     0      10     10.1.1.4:53                         *:*
  LISTEN     0      10     10.1.1.5:53                         *:*
  LISTEN     0      10     10.1.1.6:53                         *:*
  LISTEN     0      10     10.1.1.7:53                         *:*
  LISTEN     0      10     10.1.1.8:53                         *:*
  LISTEN     0      10     10.1.1.9:53                         *:*
  LISTEN     0      10     10.1.1.10:53                       *:*
Additional info:
  Fix with :
  
  sed -i "/^Requires=/ aRequires=network.target" /usr/lib/systemd/system/named-chroot.service
Comment 2 Tomáš Hozza 2016-05-10 04:16:15 EDT

*** This bug has been marked as a duplicate of bug 1294506 ***

Note You need to log in before you can comment on or make changes to this bug.