Bug 1301914 - Instance are not destroyed on the host after a successful evacuation
Instance are not destroyed on the host after a successful evacuation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Sylvain Bauza
Joe H. Rahme
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 06:20 EST by Raoul Scarazzini
Modified: 2016-04-07 17:26 EDT (History)
18 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.1-5.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, when a source compute node is back up after a migration, instances that have been successfully evacuated from it when the node was down were not deleted. A result of having the non-deleted instances makes it impossible to evacuate them. With this update, the successful migration status when evacuating an instance is now verified for knowing which instance to delete when a compute node is back up and running again. As a result, instances can be evacuated from one host to another, regardless of their previous locations.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:26:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1518200 None None None 2016-01-26 06:46 EST
OpenStack gerrit 250101 None None None 2016-01-26 06:44 EST

  None (edit)
Description Raoul Scarazzini 2016-01-26 06:20:47 EST
Description of problem:

When an host comes up after its instances has been evacuated it doesn't destroy them. This causes a failure while those instances are evacuated back to this original host.

How reproducible:

Configure instance-ha on an OSPd 8 environment (like it is explained here https://access.redhat.com/articles/1544823) and then make a host evacuate its instances while hardly reset it. Then do other evacuations until the instances turn back to their original host.

Actual results:

Instances fails to migrate.

Expected results:

Instances successfully migrates.
Comment 4 errata-xmlrpc 2016-04-07 17:26:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.