Bug 1301916 - Tracker bug -- 7.2.2 respin of rsyslog-docker
Tracker bug -- 7.2.2 respin of rsyslog-docker
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog-docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Eliska Slobodova
atomic-bugs@redhat.com
Vikram Goyal
: Tracking
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 06:37 EST by Eliska Slobodova
Modified: 2016-02-16 13:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1316125 (view as bug list)
Environment:
Last Closed: 2016-02-16 13:20:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eliska Slobodova 2016-01-26 06:37:31 EST
Tracking the 7.2.2 respin of the rsyslog-docker image.
Comment 3 Alex Jia 2016-02-05 05:10:51 EST
I gave a try on rhel7/rsyslog:latest(b98636a98907), the docker run w/ interactive mode will hang forever, and I can't get a useful debug information from docker logs, when tried to type ctrl+c several times, I got error like "rsyslogd: sd_journal_get_cursor() failed: 'Cannot assign requested address'", the test steps as follows:

1. run rsyslog container

# docker run -it registry.access.redhat.com/rhel7/rsyslog
Usage of loopback devices is strongly discouraged for production use. Either use `--storage-opt dm.thinpooldev` or use `--storage-opt dm.no_warn_on_loop_devices=true` to suppress this warning.


NOTE: docker run command hang forever.

2. open a new terminal window to check logs of running container

# docker ps
CONTAINER ID        IMAGE                                      COMMAND             CREATED             STATUS              PORTS               NAMES
3c0e51163d36        registry.access.redhat.com/rhel7/rsyslog   "/bin/rsyslog.sh"   41 seconds ago      Up 40 seconds                           hungry_poitras

# docker logs 3c0e51163d36

NOTE: nothing is in here.

3. back to above terminal window of step 1 and type ctrl+c several times.

^C^C^C^Crsyslogd: sd_journal_get_cursor() failed: 'Cannot assign requested address'
Comment 8 errata-xmlrpc 2016-02-16 13:20:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0237.html

Note You need to log in before you can comment on or make changes to this bug.