Bug 1301927 - [RFE] Check the username and password before the node introspection starts
[RFE] Check the username and password before the node introspection starts
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: cchase
Tasos Papaioannou
Dan Macpherson
: FutureFeature, Triaged
Depends On:
Blocks: 1370500
  Show dependency treegraph
 
Reported: 2016-01-26 07:01 EST by Antonin Pagac
Modified: 2016-09-13 12:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1370500 (view as bug list)
Environment:
Last Closed: 2016-09-13 12:24:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2016-01-26 07:01:35 EST
Description of problem:
During the node registration step of RHELOSP deployment, a validation check is needed for username/password for pxe_ipmitool or pxe_ssh. If user made a typo, he must wait for the introspection timeout, which seems like a waste of time.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jason Montleon 2016-01-26 16:02:57 EST
If you enter bad credentials the node can't power on and I'm pretty sure it fails and causes a fail in RHCI pretty immediately, at least with pxe_ssh. Do you have hardware with a ipmi interface so we can take a look at how pxe_ipmitool behaves?
Comment 7 jmagen@redhat.com 2016-07-28 10:03:21 EDT
I discussed with dev team and their doesn't seem to be an easy way to verify the username/pass before node inspection.
Comment 8 Jason Montleon 2016-08-05 09:13:16 EDT
Can you please re-test this.

From what we're seeing, with pxe+ssh at least, the failure is very fast and the node(s) that introspection is unsuccessfully attempted on are properly removed.

Note, there is a separate bug being worked on in that the error message that authentication is not being displayed that is being worked on.
Comment 9 cchase 2016-08-08 11:30:24 EDT
https://github.com/fusor/fusor/pull/1131

The node was being autodeleted (and clearing the error message).  Now that we allow manual deletion of nodes, it was unnecessary to autodelete it.  The error will now show as will the faulty node.
Comment 10 Tasos Papaioannou 2016-08-25 10:42:57 EDT
Failure is pretty quick with invalid SSH username/password. When using invalid IPMI username/password, the Node Auto-detection window hangs on "Detecting nodes..."

This can easily be reproduced by entering an IP address for a host that is not an actual IPMI interface. I have a window still hanging after 30 minutes.
Comment 11 cchase 2016-08-26 08:42:30 EDT
We might want a different BZ for this.  I'm fairly sure we can fix this, but this looks to be a separate issue from the original.  

The original bug was about the introspection taking a long time to fail if you entered incorrect info when adding/registering a node, not about the node auto-detection.  Also, if the auto-detection is taking too long, I imagine the user would just click the cancel button, go back, and check his info.  Most of those other failures are pretty quick.  

Having said that, this seems to be about IPMI auto-detection not timing out and deserves a separate BZ.
Comment 14 errata-xmlrpc 2016-09-13 12:24:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.