Bug 1301955 - rubygem-rails missing dependencies
rubygem-rails missing dependencies
Status: ASSIGNED
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-rails (Show other bugs)
epel7
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 07:44 EST by Christopher Bartz
Modified: 2017-04-13 00:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Bartz 2016-01-26 07:44:29 EST
Description of problem:

The command yum install rubygem-rails does fail, because it seems that another package needed (rubygem) is missing in the repository.


Version-Release number of selected component (if applicable): 4.2.5


How reproducible:
Install the package using yum.

Steps to Reproduce:
1. yum install -y rubygem-rails


Actual results:
Resolving Dependencies
--> Running transaction check
---> Package rubygem-rails.noarch 1:4.2.5-2.el7 will be installed
--> Processing Dependency: rubygem(actionmailer) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activerecord) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activeresource) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activesupport) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(actionpack) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(railties) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(bundler) >= 1.0 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Running transaction check
---> Package rubygem-bundler.noarch 0:1.7.8-3.el7 will be installed
--> Processing Dependency: rubygem(thor) >= 0.19.0 for package: rubygem-bundler-1.7.8-3.el7.noarch
--> Processing Dependency: rubygem(net-http-persistent) for package: rubygem-bundler-1.7.8-3.el7.noarch
---> Package rubygem-rails.noarch 1:4.2.5-2.el7 will be installed
--> Processing Dependency: rubygem(actionmailer) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activerecord) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activeresource) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activesupport) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(actionpack) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(railties) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Running transaction check
---> Package rubygem-net-http-persistent.noarch 0:2.8-5.el7 will be installed
---> Package rubygem-rails.noarch 1:4.2.5-2.el7 will be installed
--> Processing Dependency: rubygem(actionmailer) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activerecord) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activeresource) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(activesupport) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(actionpack) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
--> Processing Dependency: rubygem(railties) = 4.2.5 for package: 1:rubygem-rails-4.2.5-2.el7.noarch
---> Package rubygem-thor.noarch 0:0.19.1-1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel7-centos7-x86_64)
           Requires: rubygem(activerecord) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel7-centos7-x86_64)
           Requires: rubygem(actionmailer) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel7-centos7-x86_64)
           Requires: rubygem(railties) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel7-centos7-x86_64)
           Requires: rubygem(actionpack) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel7-centos7-x86_64)
           Requires: rubygem(activeresource) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel7-centos7-x86_64)
           Requires: rubygem(activesupport) = 4.2.5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Tuomo Soini 2016-03-23 16:34:56 EDT
Please remove this package from epel7. It was never working.
Comment 2 Dave Olsthoorn 2016-04-14 03:49:51 EDT
This is still broken:

Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel)
           Requires: rubygem(actionpack) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel)
           Requires: rubygem(actionmailer) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel)
           Requires: rubygem(activesupport) = 4.2.5
           Available: 1:rubygem-activesupport-4.2.6-1.el7.noarch (epel)
               rubygem(activesupport) = 4.2.6
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel)
           Requires: rubygem(activerecord) = 4.2.5
Error: Package: 1:rubygem-rails-4.2.5-2.el7.noarch (epel)
           Requires: rubygem(activeresource) = 4.2.5
Comment 3 Troy Dawson 2016-04-29 17:25:48 EDT
I have attempted to remove the package using the instructions here, specifically for epel
http://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life

It seems like it only halfway worked.
I'll give it a week or two to see if it was completely removed using the automated way.
Comment 4 greg.hellings 2016-05-12 11:08:06 EDT
Sorry, I am still working through the dependency tree for Rails. There were a large number of missing packages in the EPEL branches that still need to be built for Rails itself to be installable.
Comment 5 Jesús M. Navarro 2017-03-17 07:49:20 EDT
The same error is still there...

Any news?

Note You need to log in before you can comment on or make changes to this bug.