Bug 1301992 - The vm.placement_policy.affinity element isn't populated
The vm.placement_policy.affinity element isn't populated
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Juan Hernández
Artyom
: Regression, Triaged
Depends On:
Blocks: 1305535
  Show dependency treegraph
 
Reported: 2016-01-26 08:51 EST by Juan Hernández
Modified: 2016-02-18 06:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:16:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
mgoldboi: planning_ack+
oourfali: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52760 master MERGED restapi: Populate vm.placement_policy.affinity 2016-01-26 10:41 EST
oVirt gerrit 52761 ovirt-engine-3.6 MERGED restapi: Populate vm.placement_policy.affinity 2016-01-26 11:14 EST

  None (edit)
Description Juan Hernández 2016-01-26 08:51:49 EST
The vm.placement_policy.affinity element should be populated, but it isn't.

The expected output is something like this:

  GET /vms/{vm:id}
  <vm>
    ...
    <placement_policy>
      <affinity>migratable|user_migratable|pinned</affinity>
    </placement_policy>
    ...
  </vm>

But the actual output is like this:

  GET /vms/{vm:id}
  <vm>
    ...
    <placement_policy/>
    ...
  </vm>

I think that this regression was introduced in version 3.6.1 of the engine by the following change:

  https://gerrit.ovirt.org/46722
  https://gerrit.ovirt.org/#/c/46722/2/backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/VmMapper.java
Comment 1 Red Hat Bugzilla Rules Engine 2016-01-26 08:51:51 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Juan Hernández 2016-01-26 10:16:37 EST
This bug causes an issue in the ManageIQ oVirt provider:

  [Capablanca] - Refresh relationships fails for oVirt (RHEV) provider
  https://github.com/ManageIQ/manageiq/issues/5741
Comment 3 Artyom 2016-02-01 08:17:24 EST
Verified on rhevm-restapi-3.6.3-0.1.el6.noarch
output of get
<placement_policy>
<affinity>pinned</affinity>
</placement_policy>

Note You need to log in before you can comment on or make changes to this bug.