Bug 1301994 - repository sync sheduled by sync plan returns: can't convert String into Integer
repository sync sheduled by sync plan returns: can't convert String into Integer
Status: CLOSED DUPLICATE of bug 1301909
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity unspecified with 1 vote (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 08:53 EST by Stefan Nemeth
Modified: 2017-04-25 12:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 12:37:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Nemeth 2016-01-26 08:53:22 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.install satellite 6.1.6 on rhel 7.2
2.create sync plan 
3.see results

Actual results:

Sync Incomplete

 can't convert String into Integer

Expected results:

syncing complete

Additional info:

Actions::Pulp::Repository::Sync
Input:
{"pulp_id"=>
  "test-Red_Hat_Software_Collections__for_RHEL_Server_-Red_Hat_Software_Collections_Source_RPMs_for_Red_Hat_Enterprise_Linux_7_Server_x86_64_7Server",
 "task_id"=>"aedd63d9-8a92-47a8-b22b-f4f897216f62",
 "remote_user"=>"admin",
 "remote_cp_user"=>"foreman_admin",
 "locale"=>"en"}
Output:
{}
Exception:
TypeError: can't convert String into Integer
Backtrace:
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/repository/sync.rb:54:in `[]'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/repository/sync.rb:54:in `block in contents_changed?'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/repository/sync.rb:54:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/repository/sync.rb:54:in `find'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/repository/sync.rb:54:in `contents_changed?'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/repository/sync.rb:49:in `external_task='
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action/polling.rb:83:in `initiate_external_action'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action/polling.rb:18:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action/cancellable.rb:9:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/pulp/abstract_async_task.rb:57:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:487:in `block (3 levels) in execute_run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:26:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:26:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware.rb:16:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware.rb:25:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:22:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:26:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware.rb:16:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:27:in `block in run'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:57:in `block (2 levels) in as_remote_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/katello/util/thread_session.rb:84:in `pulp_config'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:43:in `as_pulp_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:56:in `block in as_remote_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/katello/util/thread_session.rb:91:in `cp_config'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:38:in `as_cp_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:55:in `as_remote_user'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/remote_action.rb:27:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:22:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:26:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware.rb:16:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action/progress.rb:30:in `with_progress_calculation'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action/progress.rb:16:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:22:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:26:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware.rb:16:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/keep_locale.rb:23:in `block in run'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/keep_locale.rb:34:in `with_locale'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.81/app/lib/actions/middleware/keep_locale.rb:23:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/stack.rb:22:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/middleware/world.rb:30:in `execute'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:486:in `block (2 levels) in execute_run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:485:in `catch'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:485:in `block in execute_run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:402:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:402:in `block in with_error_handling'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:402:in `catch'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:402:in `with_error_handling'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:480:in `execute_run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/action.rb:262:in `execute'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:9:in `block (2 levels) in execute'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/execution_plan/steps/abstract.rb:155:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/execution_plan/steps/abstract.rb:155:in `with_meta_calculation'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:8:in `block in execute'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:22:in `open_action'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/execution_plan/steps/abstract_flow_step.rb:7:in `execute'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/executors/parallel/worker.rb:20:in `block in on_message'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:859:in `block in assigns'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `tap'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:858:in `assigns'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:138:in `match_value'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:116:in `block in match'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/algebrick-0.4.0/lib/algebrick.rb:115:in `match'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/executors/parallel/worker.rb:17:in `on_message'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:82:in `on_envelope'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:72:in `receive'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:99:in `block (2 levels) in run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:99:in `loop'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:99:in `block in run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:99:in `catch'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:99:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/dynflow-0.7.7.9/lib/dynflow/micro_actor.rb:13:in `block in initialize'
/opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
Action:
Actions::Katello::Repository::IndexContent
Input:
{"id"=>6,
 "contents_changed"=>Step(3).output[:contents_changed],
 "current_user_id"=>1,
 "locale"=>"en"}
Output:
{}
Action:
Actions::Katello::Repository::UpdateMedia
Input:
{"repo_id"=>6,
 "contents_changed"=>Step(3).output[:contents_changed],
 "locale"=>"en"}
Output:
{}
Action:
Actions::Katello::Repository::ErrataMail
Input:
{"repo"=>6,
 "last_updated"=>"2016-01-19 15:23:31 UTC",
 "contents_changed"=>Step(3).output[:contents_changed],
 "locale"=>"en"}
Output:
{}
Action:
Actions::Katello::Repository::ErrataMail
Input:
{"repo"=>6,
 "last_updated"=>"2016-01-19 15:23:31 UTC",
 "contents_changed"=>Step(3).output[:contents_changed],
 "locale"=>"en"}
Output:
{}
Action:
Actions::Katello::Repository::Sync
Input:
{"repository"=>
  {"id"=>6,
   "name"=>
    "Red Hat Software Collections Source RPMs for Red Hat Enterprise Linux 7 Server x86_64 7Server",
   "label"=>
    "Red_Hat_Software_Collections_Source_RPMs_for_Red_Hat_Enterprise_Linux_7_Server_x86_64_7Server"},
 "product"=>
  {"id"=>44,
   "name"=>"Red Hat Software Collections for RHEL Server",
   "label"=>"Red_Hat_Software_Collections__for_RHEL_Server_",
   "cp_id"=>"201"},
 "provider"=>{"id"=>4, "name"=>"Red Hat"},
 "organization"=>{"id"=>3, "name"=>"test", "label"=>"test"},
 "services_checked"=>["pulp", "pulp_auth"],
 "id"=>6,
 "sync_result"=>Step(3).output,
 "user_id"=>1,
 "contents_changed"=>Step(3).output[:contents_changed],
 "current_user_id"=>1,
 "locale"=>"en"}
Output:
{}
Action:
Actions::Katello::Repository::Sync
Input:
{"repository"=>
  {"id"=>6,
   "name"=>
    "Red Hat Software Collections Source RPMs for Red Hat Enterprise Linux 7 Server x86_64 7Server",
   "label"=>
    "Red_Hat_Software_Collections_Source_RPMs_for_Red_Hat_Enterprise_Linux_7_Server_x86_64_7Server"},
 "product"=>
  {"id"=>44,
   "name"=>"Red Hat Software Collections for RHEL Server",
   "label"=>"Red_Hat_Software_Collections__for_RHEL_Server_",
   "cp_id"=>"201"},
 "provider"=>{"id"=>4, "name"=>"Red Hat"},
 "organization"=>{"id"=>3, "name"=>"test", "label"=>"test"},
 "services_checked"=>["pulp", "pulp_auth"],
 "id"=>6,
 "sync_result"=>Step(3).output,
 "user_id"=>1,
 "contents_changed"=>Step(3).output[:contents_changed],
 "current_user_id"=>1,
 "locale"=>"en"}
Output:
{}
Action:
Actions::Pulp::Repository::RegenerateApplicability
Input:
{"pulp_id"=>
  "test-Red_Hat_Software_Collections__for_RHEL_Server_-Red_Hat_Software_Collections_Source_RPMs_for_Red_Hat_Enterprise_Linux_7_Server_x86_64_7Server",
 "contents_changed"=>Step(3).output[:contents_changed],
 "remote_user"=>"admin",
 "remote_cp_user"=>"foreman_admin",
 "locale"=>"en"}
Output:
{}
Comment 1 Alessandro Soraruf 2016-01-29 04:28:53 EST
The same on rhel 6.7
Comment 2 Bryan Kearney 2016-03-21 12:37:37 EDT
This should have been fixed int he 6.1.6 errata. Can you please verify that this was installed and that the services were updated? If this is still not fixed, please feel free to re-open.

*** This bug has been marked as a duplicate of bug 1301909 ***
Comment 3 Bryan Kearney 2016-03-21 12:39:23 EDT
This should have been fixed int he 6.1.6 errata. Can you please verify that this was installed and that the services were updated? If this is still not fixed, please feel free to re-open.
Comment 4 Alessandro Soraruf 2016-03-23 08:41:33 EDT
Yes, I confirm that it has been fixed in 6.1.6.

Thanks

Note You need to log in before you can comment on or make changes to this bug.