Bug 130200 - Pyrex has missing dependency
Pyrex has missing dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Pyrex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-17 19:36 EDT by Steve Grubb
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 12:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that adds the Requires (398 bytes, patch)
2004-08-17 19:38 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2004-08-17 19:36:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
When Pyrex is used, it needs to have python-devel available to it.
Building dbus, for example, doesn't work unless there is a Requires:
python-devel against the package.

Version-Release number of selected component (if applicable):
Pyrex-0.9.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e python-devel
2. rpmbuild -bb dbus.spec

Actual Results:  Message saying headers weren't found.

Expected Results:  A message saying where the dbus rpm was written.

Additional info: I will attach a patch that addresses this.
Comment 1 Steve Grubb 2004-08-17 19:38:10 EDT
Created attachment 102814 [details]
Patch that adds the Requires

Please apply
Comment 2 John (J5) Palmieri 2004-08-18 10:28:09 EDT
This should be a BuildRequires for dbus but since Pyrex is a
development library I see no problem requiring python-devel for Pyrex.
 Patch accepted. Thanks.
Comment 3 Steve Grubb 2004-08-18 11:13:11 EDT
Can you think of any other package that uses Pyrex in its build
process? Does Pyrex complete its job for that package even without
python-devel being installed? If the answer is yes, a package does
indeed use Pyrex to build and does not need python-devel, then I would
agree that it is a BuildRequires against dbus.

However, if no package that uses Pyrex can be built without also
needing python-devel, then its far easier to put the Requires here and
just be done with it. Otherwise you have to add it to all packages
that use Pyrex.
Comment 4 John (J5) Palmieri 2004-08-18 12:53:53 EDT
No other packages in Fedora use Pyrex.  Anyway it is a moot point
since I have accepted the patch and feel there are good reasons for
having it in here. 

Built. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.