Bug 1302000 - memtest-setup --help does not print help
memtest-setup --help does not print help
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: memtest86+ (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 08:56 EST by Karel Volný
Modified: 2016-05-10 20:32 EDT (History)
0 users

See Also:
Fixed In Version: memtest86+-5.01-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: Previously the memtest-setup command didn't support the --help parameter. Consequence: This parameter was mentioned in the manual page, but unrecognized by the memtest-setup command which may confuse users and lower user experience. Fix: The memtest-setup command was fixed to support the --help parameter. Result: Now the memtest-setup supports the --help command and is consitent with the manual page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:32:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (574 bytes, patch)
2016-01-26 09:09 EST, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Karel Volný 2016-01-26 08:56:00 EST
Description of problem:
Trying to get help from memtest-setup, it rather seems to try to perform the installation than to return just the help message.

Version-Release number of selected component (if applicable):
memtest86+-5.01-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. memtest-setup --help

Actual results:
/boot/elf-memtest86+-5.01 is already configured.  Exiting...

Expected results:
memtest-setup installs Memtest86+ into your GRUB boot loader menu.

Usage: memtest-setup [options]

Options:
       -h, --help
              Prints this help and exits.

Additional info:
from the man page:
OPTIONS
       -h, --help
              Shows help.
Comment 2 Jaroslav Škarvada 2016-01-26 09:09 EST
Created attachment 1118530 [details]
Proposed fix

Thanks for catching, I forgot to backport the switch :)
Comment 7 errata-xmlrpc 2016-05-10 20:32:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0907.html

Note You need to log in before you can comment on or make changes to this bug.