Bug 1302001 - XMLRPC API of mom breaks on host with 193270 MiB ram
XMLRPC API of mom breaks on host with 193270 MiB ram
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mom (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity high
: ovirt-3.6.3
: 3.6.3
Assigned To: Martin Sivák
Shira Maximov
: Regression
Depends On: 1294833
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 08:56 EST by Martin Sivák
Modified: 2016-03-09 09:44 EST (History)
16 users (show)

See Also:
Fixed In Version: mom-0.5.2-1
Doc Type: Bug Fix
Doc Text:
VDSM uses XML-RPC to communicate with MoM, and XML-RPC only supports int32 type for numbers. As a result, hosts with big memory overflowed the int32 type and an error was returned when running the vdsClient -s 0 getVdsStats command. With this update, MoM is configured to use i8 XML-RPC extension for transferring big numbers. VDSM can now properly retrieve statistics from MoM on hosts with big memory.
Story Points: ---
Clone Of: 1294833
Environment:
Last Closed: 2016-03-09 09:44:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51396 None None None 2016-01-26 08:56 EST

  None (edit)
Comment 5 Shira Maximov 2016-02-07 10:07:53 EST
verified on : 
Red Hat Enterprise Virtualization Manager Version: 3.6.3-0.1.el6 
mom-0.5.2-1.el7ev.noarch

the verification run on PPC host with  251 GB memory 

verification steps : 
run vdsClient -s 0 getVdsStats , the command worked.
Comment 9 errata-xmlrpc 2016-03-09 09:44:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0384.html

Note You need to log in before you can comment on or make changes to this bug.