Bug 1302005 - documentation lacks informations about serial console support
documentation lacks informations about serial console support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: memtest86+ (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 09:07 EST by Karel Volný
Modified: 2016-05-10 20:32 EDT (History)
0 users

See Also:
Fixed In Version: memtest86+-5.01-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: Previously there was no distribution specific documentation shipped together with the memtest86+. Consequence: It could be hard for users to find information about new features and how to use them on RHEL. Fix: Distribution specific README file was added to the memtest86+ package which describes new features and RHEL specific usage. Result: Now the distribution specific documentation is available in README file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:32:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2016-01-26 09:07:08 EST
Description of problem:
I haven't found any information how to setup memtest86+ to use the serial console. The README mentions that it needs to be enabled before compilation, but doesn't give any clue how to activate/configure the serial console on boot.

Version-Release number of selected component (if applicable):
memtest86+-5.01-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. examine /usr/share/doc/memtest86+-5.01/README
2. try to find any other relevant documentation for the package (man pages etc.)

Actual results:
1. no mention how to configure serial parameters on grub commandline
2. none found

Expected results:
1. information that you have to add something like "console=ttyS4,115200n8" on kernel line in grub
2. manpage for memtest86+ exists, explaining usage in RHEL (e.g. the grub line added by memtest-setup is different from what is in README, why, what is this elf-memtest86 thing about etc.)

Additional info:
Comment 2 Jaroslav Škarvada 2016-01-26 09:26:14 EST
There is currently no memtest86+ manual page, we could add one for better user experience.
Comment 3 Jaroslav Škarvada 2016-02-12 08:47:40 EST
Adding README.dist instead of manual page, because the distro specific manual page would hardly fit any manual section (maybe section 7) - memtest stays aside the system and readme files are easier to read/print, not counting there could be conflict later if upstream adds some manual page for it.
Comment 7 errata-xmlrpc 2016-05-10 20:32:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0907.html

Note You need to log in before you can comment on or make changes to this bug.