Bug 130202 - hal has missing dependency
hal has missing dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-17 19:56 EDT by Steve Grubb
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 16:20:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix configure (418 bytes, patch)
2004-08-17 19:57 EDT, Steve Grubb
no flags Details | Diff
patch to fix spec file (1.00 KB, patch)
2004-08-17 19:58 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2004-08-17 19:56:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
hal has missing build dependency on hwdata. It will not compile
without it. python is not needed for a BuildRequires because
python-devel requires python to be installed. I deleted the
requirement for docbook-dtds. The config file looks for it and works
without it.

I also found a problem in that gobject was not being linked against.
The problem comes from the configure.in file not having it specified.
But since autoconf is not called from the specfile, I chose to just
fix configure. 

I will attach 2 patches that fix all the above issues.

Version-Release number of selected component (if applicable):
hal-0.2.97

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb hal.spec

Actual Results:  Various message about something missing or linking
errors.

Expected Results:  A message saying where the rpm was written.

Additional info:
Comment 1 Steve Grubb 2004-08-17 19:57:27 EDT
Created attachment 102816 [details]
Patch to fix configure

Please add to package.
Comment 2 Steve Grubb 2004-08-17 19:58:06 EDT
Created attachment 102817 [details]
patch to fix spec file

Please apply
Comment 3 John (J5) Palmieri 2004-08-18 10:50:35 EDT
Reasigned to Dave.  He is the new maintainer of the hal packages. 
Configure.in patches should go upsteam.
Comment 4 David Zeuthen 2004-08-19 16:20:42 EDT
I've applied the configure.in patch upstream and the hal.spec to the
package. Should appear in Rawhide with the next update. Thanks for the
patches.

Note You need to log in before you can comment on or make changes to this bug.