Bug 1302081 - [DOC] When one of the leading zeros of the last IPv6 quartet is omitted the public VIP gets set on all 3 controllers
[DOC] When one of the leading zeros of the last IPv6 quartet is omitted the p...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
low Severity low
: ---
: 10.0 (Newton)
Assigned To: Dan Macpherson
RHOS Documentation Team
: Documentation
Depends On: 1301923
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 12:46 EST by Angus Thomas
Modified: 2017-09-12 21:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Address ranges entered for the `AllocationPools` IPv6 networks and IP allocation pools must be input in a valid format according to RFC 5952. Consequently, invalid entries will result in an error. As a result, IPv6 addresses should be entered in a valid format: Leading zeros can be omitted or entered in full, and repeating sequences of zeros may be replaced by "::". For example, an IP address of "fd00:0001:0000:0000:00a1:00b2:00c3:0010" may be represented as: "fd00:1::a1:b2:c3:10", but not as: "fd00:01::0b2:0c3:10", because there are an invalid number of leading zeros (01, 0b2, 0c3). The field must be truncated of leading zeros or fully padded.
Story Points: ---
Clone Of: 1301923
Environment:
Last Closed: 2017-09-12 21:16:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angus Thomas 2016-01-26 12:46:28 EST
+++ This bug was initially created as a clone of Bug #1301923 +++

Description of problem:
When one of the leading zeros of the last IPv6 quartet is omitted the public VIP gets set on all 3 controllers.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-112.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy IPv6 enabled overcloud with the following external allocation pool:
  ExternalInterfaceDefaultRoute: 2001:db8:fd00:1000:dead:beef:cafe:f00
  ExternalNetCidr: '2001:db8:fd00:1000::/64'
  ExternalAllocationPools: [{'start': '2001:db8:fd00:1000:dead:beef:cafe:001', 'end': '2001:db8:fd00:1000:dead:beef:cafe:009'}] 


Actual results:
stack@instack:~>>> for ctrl in $(nova list | grep controller | awk {'print $12'} | awk -F'=' {'print $2'}); do ssh heat-admin@$ctrl 'cat /etc/hostname; /usr/sbin/ip a s dev vlan10 | grep inet6 | grep 2001';done
overcloud-controller-0.localdomain
    inet6 2001:db8:fd00:1000:dead:beef:cafe:1/64 scope global tentative dadfailed 
    inet6 2001:db8:fd00:1000:dead:beef:cafe:3/64 scope global 
overcloud-controller-1.localdomain
    inet6 2001:db8:fd00:1000:dead:beef:cafe:1/64 scope global tentative dadfailed 
    inet6 2001:db8:fd00:1000:dead:beef:cafe:2/64 scope global 
overcloud-controller-2.localdomain
    inet6 2001:db8:fd00:1000:dead:beef:cafe:1/64 scope global 
    inet6 2001:db8:fd00:1000:dead:beef:cafe:4/64 scope global 

 ip-2001.db8.fd00.1000.dead.beef.cafe.001	(ocf::heartbeat:IPaddr2):	Stopped

Expected results:
The VIP resource is started and the IP address gets set only on one of the nodes at a time.

Additional info:
Attaching /var/log/messages.

--- Additional comment from Angus Thomas on 2016-01-26 12:45:00 EST ---

We should add a 7.3 release note for this.
Comment 2 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Dan Sneddon 2016-10-14 12:00:45 EDT
Entering addresses with a invalid number of leading zeros will lead to errors. According to RFC 5952, leading zeros within each hexadecimal group (between the ":" delineators) must be fully-padded or all leading zeros may be omitted. Doc text has been updated, and the installation and usage guide should be updated appropriately.
Comment 5 Dan Macpherson 2017-09-12 01:04:27 EDT
Cleaning up my backlog and I found this bug. I checked in the IPv6 Guide and it looks like this is mentioned:

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/ipv6_networking_for_the_overcloud/#defining_ipv6_networking

===
Notice you can also represent IPv6 addresses without leading zeros in each bit group and omit a set of zero bit groups once per IP address. In our example, you can represent the 0db8 bit grouping as just db8 and omit the three sets of 0000 bit groups, which shortens the representation from 2001:0db8:88ec:9fb3:0000:0000:0000:0001 to 2001:db8:88ec:9fb3::1. For more information, see "RFC 5952: A Recommendation for IPv6 Address Text Representation"
===

Dan, are we okay to close this BZ?
Comment 6 Dan Sneddon 2017-09-12 15:16:02 EDT
(In reply to Dan Macpherson from comment #5)
> Cleaning up my backlog and I found this bug. I checked in the IPv6 Guide and
> it looks like this is mentioned:
> 
> https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/
> html-single/ipv6_networking_for_the_overcloud/#defining_ipv6_networking
> 
> ===
> Notice you can also represent IPv6 addresses without leading zeros in each
> bit group and omit a set of zero bit groups once per IP address. In our
> example, you can represent the 0db8 bit grouping as just db8 and omit the
> three sets of 0000 bit groups, which shortens the representation from
> 2001:0db8:88ec:9fb3:0000:0000:0000:0001 to 2001:db8:88ec:9fb3::1. For more
> information, see "RFC 5952: A Recommendation for IPv6 Address Text
> Representation"
> ===
> 
> Dan, are we okay to close this BZ?

Yes, we are OK to close this BZ, it is documented. Just to be clear, the example you gave (2001:db8:88ec:9fb3::1) works, as does the version with all the zeroes, and even this (2001:db8:88ec:9fb3::0001), what doesn't work is an invalid number of zeroes, such as 2001:db8:88ec:9fb3::01.
Comment 7 Dan Macpherson 2017-09-12 21:16:13 EDT
Thanks, Dan! Closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.