Bug 1302100 - boost-devel provides several libs which are required by other packages but has packaging problems
boost-devel provides several libs which are required by other packages but ha...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 13:56 EST by George R. Goffe
Modified: 2016-08-01 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 18:48:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2016-01-26 13:56:27 EST
Description of problem:
dnf --best upgrade produced a list of packages dependent on other packages with problems. boost-devel is one such package. It appears to be installed on my system (F24_x86_64) but "dnf reinstall boost-devel shows as unavailable even thought it IS installed on my system (boost-devel-1.59.0-10.fc24.x86_64).

Version-Release number of selected component (if applicable):
boost-devel-1.59.0-10.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1.with all groups of packages installed run
2.dnf --best upgrade
3.see additional information below.

Actual results:


Expected results:


Additional info:

package ogre-1.9.0-13.fc24.x86_64                                   requires libboost_atomic.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-rtss-1.9.0-13.fc24.x86_64                              requires libboost_atomic.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-overlay-1.9.0-13.fc24.x86_64                           requires libboost_chrono.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-terrain-1.9.0-13.fc24.x86_64                           requires libboost_chrono.so.1.59.0()(64bit), but none of the providers can be installed.
package sumwars-0.5.8-7.fc24.x86_64                                 requires libboost_chrono.so.1.59.0()(64bit), but none of the providers can be installed.
package blender-1:2.76-4.fc24.x86_64                                requires libboost_date_time.so.1.59.0()(64bit), but none of the providers can be installed.
package ember-0.7.2-11.fc24.x86_64                                  requires libboost_date_time.so.1.59.0()(64bit), but none of the providers can be installed.
package sumwars-0.5.8-7.fc24.x86_64                                 requires libboost_date_time.so.1.59.0()(64bit), but none of the providers can be installed.
package ember-0.7.2-11.fc24.x86_64                                  requires libboost_date_time.so.1.59.0()(64bit), but none of the providers can be installed.
package mkvtoolnix-8.8.0-1.fc24.x86_64                              requires libboost_filesystem.so.1.59.0()(64bit), but none of the providers can be installed.
package sumwars-0.5.8-7.fc24.x86_64                                 requires libboost_filesystem.so.1.59.0()(64bit), but none of the providers can be installed.
package openscad-2015.03.2-4.fc24.x86_64                            requires libboost_filesystem.so.1.59.0()(64bit), but none of the providers can be installed.
package mkvtoolnix-gui-8.8.0-1.fc24.x86_64                          requires libboost_filesystem.so.1.59.0()(64bit), but none of the providers can be installed.
package mkvtoolnix-8.8.0-1.fc24.x86_64                              requires libboost_filesystem.so.1.59.0()(64bit), but none of the providers can be installed.
package pokerth-1.1.1-12.fc24.x86_64                                requires libboost_iostreams.so.1.59.0()(64bit), but none of the providers can be installed.
package blender-1:2.76-3.fc24.x86_64                                requires libboost_locale.so.1.59.0()(64bit), but none of the providers can be installed.
package openscad-2015.03.2-4.fc24.x86_64                            requires libboost_program_options.so.1.59.0()(64bit), but none of the providers can be installed.
package synfig-0.64.3-8.fc24.x86_64                                 requires libboost_program_options.so.1.59.0()(64bit), but none of the providers can be installed.
package synfig-0.64.3-8.fc24.x86_64                                 requires libboost_program_options.so.1.59.0()(64bit), but none of the providers can be installed.
package synfig-0.64.3-8.fc24.x86_64                                 requires libboost_program_options.so.1.59.0()(64bit), but none of the providers can be installed.
package synfig-0.64.3-8.fc24.x86_64                                 requires libboost_program_options.so.1.59.0()(64bit), but none of the providers can be installed.
package avogadro-libs-1.1.1-15.fc24.x86_64                          requires libboost_python.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_python.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_python.so.1.59.0()(64bit), but none of the providers can be installed.
package pokerth-1.1.1-12.fc24.x86_64                                requires libboost_random.so.1.59.0()(64bit), but none of the providers can be installed.
package mkvtoolnix-gui-8.8.0-1.fc24.x86_64                          requires libboost_regex.so.1.59.0()(64bit), but none of the providers can be installed.
package spring-100.0-1.fc24.x86_64                                  requires libboost_regex.so.1.59.0()(64bit), but none of the providers can be installed.
package openscad-2015.03.2-1.fc24.x86_64                            requires libboost_regex.so.1.59.0()(64bit), but none of the providers can be installed.
package spring-100.0-2.fc24.x86_64                                  requires libboost_signals.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed
package calligra-krita-2.9.10-3.fc24.x86_64                         requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package calligra-krita-libs-2.9.10-3.fc24.x86_64                    requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ember-0.7.2-11.fc24.x86_64                                  requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package funguloids-1.06-16.fc24.x86_64                              requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package iwhd-1.6-20.fc24.x86_64                                     requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-paging-1.9.0-13.fc24.x86_64                            requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package calligra-krita-2.9.10-3.fc24.x86_64                         requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package sumwars-0.5.8-7.fc24.x86_64                                 requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-terrain-1.9.0-13.fc24.x86_64                           requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-rtss-1.9.0-13.fc24.x86_64                              requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-paging-1.9.0-13.fc24.x86_64                            requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-overlay-1.9.0-13.fc24.x86_64                           requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ogre-1.9.0-13.fc24.x86_64                                   requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package iwhd-1.6-20.fc24.x86_64                                     requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package funguloids-1.06-16.fc24.x86_64                              requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package ember-0.7.2-11.fc24.x86_64                                  requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package vegastrike-0.5.1-25.r1.fc24.x86_64                          requires libboost_system.so.1.59.0()(64bit), but none of the providers can be installed.
package cegui-ogre-renderer-0.8.4-14.fc24.x86_64                    requires libboost_thread.so.1.59.0()(64bit), but none of the providers can be installed.
Comment 1 Jonathan Wakely 2016-01-26 14:05:03 EST
Boost has been updated to 1.60.0-2.fc24 in rawhide, but many of the packages you have installed (including all the ones that depend on ogre) could not be rebuilt with the new Boost so still depend on 1.59.0.  Until they are rebuilt you can't update them, because they have broken deps. This will be resolved shortly, once those packages are rebuilt, but it is not a bug in Boost.
Comment 2 George R. Goffe 2016-01-26 14:50:42 EST
Jonathan,

Thanks for your help with this problem. I'll watch for updates.

Regards,

George...
Comment 3 Jan Kurik 2016-02-24 10:33:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Jonathan Wakely 2016-08-01 18:48:53 EDT
All these packages should have been rebuilt against boost-1.60 in February, or some time since, so this should be fixed.

If any packages still can't be installed please report a bug against that package so it can be rebuilt.

Note You need to log in before you can comment on or make changes to this bug.