Bug 1302114 - kernel-PAE.i686 fails to boot on qemu
kernel-PAE.i686 fails to boot on qemu
Status: CLOSED DUPLICATE of bug 1302071
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 15:01 EST by Richard W.M. Jones
Modified: 2016-01-26 15:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 15:18:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2016-01-26 15:01:15 EST
Description of problem:

Hangs right after seabios:

Serial Graphics Adapter 06/19/15
SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (mockbuild@) Fri Jun 19 00:52:18 UTC 2015
Term: 80x24
4 0
SeaBIOS (version 1.9.0-1.fc24)
Machine UUID 7a0b0428-2db4-504c-92b7-75c04deb7c74
Booting from ROM...
Probing EDD (edd=off to disable)... ok
\x1b[2J

Version-Release number of selected component (if applicable):

qemu-system-x86-2.5.0-4.fc24.i686
seabios-bin-1.9.0-1.fc24.noarch
kernel-PAE-4.5.0-0.rc1.git0.1.fc24.i686

How reproducible:

100%

Steps to Reproduce:
1. Run libguestfs-test-tool.

Additional info:

The same kernel version boots fine on x86-64.  The problem is specific
to i686.

I also tried:

kernel-PAE-4.5.0-0.rc0.git9.1.fc24.i686  - hangs (same place)
kernel-PAE-4.5.0-0.rc0.git8.1.fc24.i686 - failed to install
kernel-PAE-4.5.0-0.rc0.git7.1.fc24.i686 - failed to install
kernel-PAE-4.5.0-0.rc0.git1.1.fc24.i686 - failed to install

All the install failures were like this:

Error: package kernel-PAE-4.5.0-0.rc0.git1.1.fc24.i686 requires kernel-PAE-core-uname-r = 4.5.0-0.rc0.git1.1.fc24.i686+PAE, but none of the providers can be installed

Perhaps these kernel packages don't have a good "downgrade" path.

Full build logs of failing build in Koji:

https://kojipkgs.fedoraproject.org//work/tasks/2014/12692014/root.log
https://kojipkgs.fedoraproject.org//work/tasks/2014/12692014/build.log
Comment 1 Josh Boyer 2016-01-26 15:18:07 EST

*** This bug has been marked as a duplicate of bug 1302071 ***

Note You need to log in before you can comment on or make changes to this bug.