Bug 1302135 - [abrt] gchemtable: gcu::Dialog::SetRealName(): gchemtable-0.14 killed by SIGABRT
[abrt] gchemtable: gcu::Dialog::SetRealName(): gchemtable-0.14 killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-chemistry-utils (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Julian Sikorski
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:2683a995d421e01fa379307a025...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 17:11 EST by Steve
Modified: 2016-02-17 15:21 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.14.10-14.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 15:21:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.82 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: cgroup (200 bytes, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: core_backtrace (14.83 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: dso_list (10.75 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: environ (1.53 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: maps (52.49 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: mountinfo (3.27 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: open_fds (917 bytes, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
File: var_log_messages (561 bytes, text/plain)
2016-01-26 17:11 EST, Steve
no flags Details
Patch (1.57 KB, patch)
2016-01-29 09:41 EST, Jean Bréfort
no flags Details | Diff

  None (edit)
Description Steve 2016-01-26 17:11:01 EST
Description of problem:
Detailed reproducer to be reported in followup comment.

Version-Release number of selected component:
gchemtable-0.14.10-11.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        gchemtable-0.14
crash_function: gcu::Dialog::SetRealName
executable:     /usr/bin/gchemtable-0.14
global_pid:     2810
kernel:         4.3.3-301.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 gcu::Dialog::SetRealName at dialog.cc:58
 #7 GChemTableCurve::GChemTableCurve at gchemtable-curve.cc:311
 #8 on_show_curve at gchemtable-curve.cc:55
 #9 _g_closure_invoke_va at gclosure.c:864
 #12 gtk_button_do_release at gtkbutton.c:1899
 #13 gtk_real_button_released at gtkbutton.c:2017
 #18 multipress_released_cb at gtkbutton.c:613
 #19 ffi_call_unix64 at ../src/x86/unix64.S:76
 #20 ffi_call at ../src/x86/ffi64.c:525
 #21 g_cclosure_marshal_generic_va at gclosure.c:1600
Comment 1 Steve 2016-01-26 17:11:04 EST
Created attachment 1118626 [details]
File: backtrace
Comment 2 Steve 2016-01-26 17:11:05 EST
Created attachment 1118627 [details]
File: cgroup
Comment 3 Steve 2016-01-26 17:11:06 EST
Created attachment 1118628 [details]
File: core_backtrace
Comment 4 Steve 2016-01-26 17:11:07 EST
Created attachment 1118629 [details]
File: dso_list
Comment 5 Steve 2016-01-26 17:11:08 EST
Created attachment 1118630 [details]
File: environ
Comment 6 Steve 2016-01-26 17:11:09 EST
Created attachment 1118631 [details]
File: limits
Comment 7 Steve 2016-01-26 17:11:10 EST
Created attachment 1118632 [details]
File: maps
Comment 8 Steve 2016-01-26 17:11:10 EST
Created attachment 1118633 [details]
File: mountinfo
Comment 9 Steve 2016-01-26 17:11:11 EST
Created attachment 1118634 [details]
File: namespaces
Comment 10 Steve 2016-01-26 17:11:12 EST
Created attachment 1118635 [details]
File: open_fds
Comment 11 Steve 2016-01-26 17:11:13 EST
Created attachment 1118636 [details]
File: proc_pid_status
Comment 12 Steve 2016-01-26 17:11:14 EST
Created attachment 1118637 [details]
File: var_log_messages
Comment 13 Steve 2016-01-26 17:27:54 EST
Steps to reproduce:

1. Start "Periodic table of the elements" from desktop.
2. Select View:Element charts:Electronegativty (sic).
3. Click "H" in periodic table.
4. Click "Electronic properties" in "Hydrogen" window.
5. Click "Show curve" for "Pauling electronegativity: 2.20".

The application exits with a core dump.
Comment 14 Julian Sikorski 2016-01-28 15:09:51 EST
It is reproducible on F22 as well. Jean, please may you look into this? Thank you!
Comment 15 Jean Bréfort 2016-01-28 15:24:25 EST
This is probably a trivial bug. But I have a serious health issue currently and can't do much for the next six months or so. If the issue is not simple, it will take time.
Comment 16 Julian Sikorski 2016-01-28 15:25:38 EST
Hi Jean,
I am sorry to hear this, wishing you a speedy recovery!
Comment 17 Jean Bréfort 2016-01-29 09:41 EST
Created attachment 1119443 [details]
Patch

Fixes the issue. Please apply since I will not release soon because of an ongoing work on ChemDraw filters that I would like to be in the next release.
Comment 18 Fedora Update System 2016-02-01 13:59:24 EST
gnome-chemistry-utils-0.14.10-13.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-482a02f6a3
Comment 19 Fedora Update System 2016-02-01 13:59:44 EST
gnome-chemistry-utils-0.14.10-10.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5616b950bc
Comment 20 Fedora Update System 2016-02-01 21:25:50 EST
gnome-chemistry-utils-0.14.10-10.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5616b950bc
Comment 21 Fedora Update System 2016-02-01 21:26:42 EST
gnome-chemistry-utils-0.14.10-13.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-482a02f6a3
Comment 22 Fedora Update System 2016-02-07 11:19:21 EST
goffice-0.10.27-1.fc23 gnumeric-1.12.27-1.fc23 gnome-chemistry-utils-0.14.10-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f078ec18c0
Comment 23 Fedora Update System 2016-02-07 11:20:41 EST
goffice-0.10.27-1.fc22 gnumeric-1.12.27-1.fc22 gnome-chemistry-utils-0.14.10-11.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8cb8ec7c6f
Comment 24 Fedora Update System 2016-02-07 23:19:51 EST
gnome-chemistry-utils-0.14.10-14.fc23, gnumeric-1.12.27-1.fc23, goffice-0.10.27-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f078ec18c0
Comment 25 Fedora Update System 2016-02-07 23:19:52 EST
gnome-chemistry-utils-0.14.10-11.fc22, gnumeric-1.12.27-1.fc22, goffice-0.10.27-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8cb8ec7c6f
Comment 26 Fedora Update System 2016-02-16 22:51:50 EST
gnome-chemistry-utils-0.14.10-14.fc23, gnumeric-1.12.27-1.fc23, goffice-0.10.27-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2016-02-16 23:18:52 EST
gnome-chemistry-utils-0.14.10-11.fc22, gnumeric-1.12.27-1.fc22, goffice-0.10.27-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.