Bug 1302142 - pkispawn overwrites files when adding subsystem to existing instance
pkispawn overwrites files when adding subsystem to existing instance
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Endi Sukma Dewata
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 17:15 EST by Matthew Harmsen
Modified: 2016-11-04 01:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: pki-core-10.3.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Harmsen 2016-01-26 17:15:48 EST
When adding a new subsystem into an existing instance pkispawn will regenerate Tomcat configuration files such as serverCertNick.conf and server.xml. So if there are subsystem-specific settings in those files they will get replaced by the settings of the new subsystem.

For example the serverCertNick.conf on a CA may initially contain the following value:
{{{
Server-Cert cert-pki-ca
}}}

When KRA is added to the same instance it could change to this:
{{{
Server-Cert cert-pki-kra
}}}

One possible solution is to not regenerate Tomcat configuration files. This means the contents of those files are controlled by the first subsystem and if the second subsystem defines a different value it will get ignored, which may be confusing to the admin.

Another solution is to verify that the second subsystem does not define different values for the parameters that will go into Tomcat configuration files. Otherwise, the installation should fail.

Another possible solution is to split Tomcat configuration from subsystem configuration into separate deployment files. When adding a new subsystem to an existing instance only the subsystem configuration is required so the admin will not accidentally change the Tomcat configuration.
Comment 2 Mike McCune 2016-03-28 18:32:18 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Geetika Kapoor 2016-07-04 06:23:31 EDT
Verified 10.3.3:

For shared tomcat instance , files server.xml and serverCertNick.conf
are not overwritten.
Comment 6 errata-xmlrpc 2016-11-04 01:22:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2396.html

Note You need to log in before you can comment on or make changes to this bug.