Bug 130215 - Printing of indic languages fails, if the font information is not correct
Printing of indic languages fails, if the font information is not correct
Status: CLOSED DUPLICATE of bug 134320
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2004-08-18 01:48 EDT by Jatin Nansi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case for hindi (580 bytes, text/plain)
2004-08-18 01:51 EDT, Jatin Nansi
no flags Details

  None (edit)
Description Jatin Nansi 2004-08-18 01:48:09 EDT
Description of problem:
Some indian fonts have incorrect font meta-information, for eg. the
Gargi font has '1.3' as the style input. Font Saab for panjabi does
not have correct lang information. When using these fonts with Gnome,
the onscreen display of hindi/panjabi works fine. But the printing
library does not pick up the font correctly. I have verified this by
modifying the Gargi font, and changing the style tag to "Regular".
Printing works well with this change.


Version-Release number of selected component (if applicable):
libgnomeprint22-2.7.1-1


How reproducible:
Every time


Steps to Reproduce:
1. Install Gargi-1.3 hindi font
2. Open the attached hindi test file in gedit
3. Print it to a postscript file, and quit gedit
4. Open the postscript file in gv
5. Uninstall Gargi-1.3 font
6. Install the gargi-new.ttf font (modified by me)
7. Open the attached hindi test file in gedit
8. Print it to a postscript file, and quit gedit
9. Open the postscript file in gv  


Actual results:
The text is just squares in the first postscript file.
The text prints correctly the second time.


Expected results:
Although the font is broken, it is working when displaying text, so it
should work while printing.


Additional info:
this has been tested on RHEL4 alpha4. 
You can get the gargi fonts from here:
http://bob.brisbane.redhat.com/~jnansi/pkgs/ttfonts-hi-1-1.noarch.rpm
http://bob.brisbane.redhat.com/~jnansi/gargi-new.ttf
The rpm contains the broken font.
I will try out changes with the panjabi font and post updates to this bug.
Comment 1 Jatin Nansi 2004-08-18 01:51:36 EDT
Created attachment 102825 [details]
test case for hindi
Comment 2 Jatin Nansi 2004-10-08 03:12:28 EDT
Same problem as bug 134320. closing as duplicate

*** This bug has been marked as a duplicate of 134320 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.