This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1302172 - The command 'dnf history info XXX' makes dnf crash
The command 'dnf history info XXX' makes dnf crash
Status: CLOSED DUPLICATE of bug 1303149
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 21:23 EST by xvr
Modified: 2016-02-01 07:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 07:24:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xvr 2016-01-26 21:23:18 EST
Description of problem:
Executing 'dnf history info XXX' results in an immediate crash of dnf, as well as sudo user or as root

Version-Release number of selected component (if applicable):
dnf-1.1.6-1.fc23

How reproducible:
always

Steps to Reproduce:
1. (sudo or root) 'dnf history info' or 'dnf history info XXX'
2.
3.

Actual results:
immediate crash of dnf

Expected results:
install history details

Additional info: python output:
# dnf history info 99
Vérification de l'expiration des métadonnées effectuée il y a 0:22:47 sur Wed Jan 27 02:49:27 2016.
ID de transaction : 99
Temps de début    : Thu Apr 30 17:33:25 2015
Début de RPMDB    : 1377:79f50bee839d7808c066436abaa050609277559c
Temps de fin :            17:33:26 2015 (1 secondes)
Fin de RPMDB : 1381:4f27f9267f1a4d9f91ba9e8dbbdc55a82285293f
Utilisateur  : Xavier Ribes <ribesx>
Code retour  : Réussi
Ligne de commande : install yumex
Transaction effectuée avec :
Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/__init__.py", line 1218, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1536, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1672, in _historyInfoCmd
    _simple_pkg(hpkg, 4, was_installed=True, pkg_max_len=pkg_max_len)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1575, in _simple_pkg
    elif ipkgs[-1] > hpkg:
  File "/usr/lib64/python3.4/functools.py", line 125, in _lt_from_le
    op_result = self.__le__(other)
  File "/usr/lib/python3.4/site-packages/dnf/yum/history.py", line 166, in __le__
    o = other.to_nevra()
AttributeError: 'Package' object has no attribute 'to_nevra'
Comment 1 Martin Ueding 2016-01-30 09:10:09 EST
This is a duplicate of 1303149.
Comment 2 Honza Silhan 2016-02-01 07:24:49 EST

*** This bug has been marked as a duplicate of bug 1303149 ***

Note You need to log in before you can comment on or make changes to this bug.