This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1302173 - [abrt] eric: HelpWindow.py:3682:__userStyleSheet:TypeError: arguments did not match any overloaded call:
[abrt] eric: HelpWindow.py:3682:__userStyleSheet:TypeError: arguments did not...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eric (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5c31e3191273a866b07c665df32...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 21:25 EST by yucef sourani
Modified: 2016-03-11 07:56 EST (History)
2 users (show)

See Also:
Fixed In Version: eric-6.1.2-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 07:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.61 KB, text/plain)
2016-01-26 21:26 EST, yucef sourani
no flags Details
File: environ (1.72 KB, text/plain)
2016-01-26 21:26 EST, yucef sourani
no flags Details

  None (edit)
Description yucef sourani 2016-01-26 21:25:59 EST
Version-Release number of selected component:
eric-6.0.7-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/lib/python3.4/site-packages/eric6/eric6_webbrowser.py
executable:     /usr/lib/python3.4/site-packages/eric6/eric6_webbrowser.py
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
HelpWindow.py:3682:__userStyleSheet:TypeError: arguments did not match any overloaded call:
  QByteArray(): too many arguments
  QByteArray(int, str): argument 1 has unexpected type 'str'
  QByteArray(QByteArray): argument 1 has unexpected type 'str'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/eric6/eric6_webbrowser.py", line 102, in <module>
    main()
  File "/usr/lib/python3.4/site-packages/eric6/eric6_webbrowser.py", line 98, in main
    installErrorHandler=True)
  File "/usr/lib/python3.4/site-packages/eric6/Toolbox/Startup.py", line 241, in simpleAppStartup
    w = mwFactory(argv)
  File "/usr/lib/python3.4/site-packages/eric6/eric6_webbrowser.py", line 73, in createMainWidget
    help = HelpWindow(home, '.', None, 'help viewer', searchWord=searchWord)
  File "/usr/lib/python3.4/site-packages/eric6/Helpviewer/HelpWindow.py", line 220, in __init__
    self.__initWebSettings()
  File "/usr/lib/python3.4/site-packages/eric6/Helpviewer/HelpWindow.py", line 335, in __initWebSettings
    settings.setUserStyleSheetUrl(self.__userStyleSheet(styleSheet))
  File "/usr/lib/python3.4/site-packages/eric6/Helpviewer/HelpWindow.py", line 3682, in __userStyleSheet
    encodedStyle = bytes(QByteArray(userStyle).toBase64()).decode()
TypeError: arguments did not match any overloaded call:
  QByteArray(): too many arguments
  QByteArray(int, str): argument 1 has unexpected type 'str'
  QByteArray(QByteArray): argument 1 has unexpected type 'str'

Local variables in innermost frame:
styleSheetFile: ''
userStyle: '{display:none !important;}'
self: <Helpviewer.HelpWindow.HelpWindow object at 0x7f94d209f708>
Comment 1 yucef sourani 2016-01-26 21:26:05 EST
Created attachment 1118653 [details]
File: backtrace
Comment 2 yucef sourani 2016-01-26 21:26:06 EST
Created attachment 1118654 [details]
File: environ
Comment 3 yucef sourani 2016-03-11 07:46:29 EST
The problem is fixed ,Thank you .

Note You need to log in before you can comment on or make changes to this bug.