Bug 1302183 - function IpNetnsCommand.exists in neutron/agent/linux/ip_lib.py cannot correctly parse ip netns output
function IpNetnsCommand.exists in neutron/agent/linux/ip_lib.py cannot correc...
Status: CLOSED DUPLICATE of bug 1292570
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-26 23:52 EST by bigswitch
Modified: 2016-10-14 12:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 12:38:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bigswitch 2016-01-26 23:52:17 EST
Description of problem:

In both RHOSP7 and RHOSP8, the function IpNetnsCommand.exists in neutron/agent/linux/ip_lib.py cannot correctly parse "ip netns" output.

Following is an example. Given the current parsing method, the (id: x) won't be stripped.
[root@overcloud-controller-2 neutron]# ip netns
qdhcp-511e26fd-ca31-4521-adba-f328d7777c1b (id: 7)
qrouter-901ab96c-7375-4cf0-9974-852d2fdbe341 (id: 6)
qdhcp-d8f491c2-b102-4ef9-8687-aae36b04a3d8 (id: 5)
qdhcp-8a1f6447-1444-41e9-bda6-ecc0d5f5607e (id: 4)
qrouter-75612b50-f359-4a20-abfe-2f2718e8e688 (id: 3)
qdhcp-702d8ba9-5baa-4df4-8873-875714fecc38 (id: 2)
qdhcp-94f53458-17ca-4b2f-9ba2-7c4b801a8d6d (id: 1)
qdhcp-1a1e4582-3c42-40e3-a667-71b08937c486 (id: 0)

The impact of this is that l3-agent will always try to create a router name space even when the name space exists.

A proper implementation of that function is at
https://github.com/openstack/neutron/blob/stable/kilo/neutron/agent/linux/ip_lib.py#L584-L591

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Assaf Muller 2016-10-14 12:38:57 EDT

*** This bug has been marked as a duplicate of bug 1292570 ***

Note You need to log in before you can comment on or make changes to this bug.