This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1302200 - Unable to get the client statedump, as /var/run/gluster directory is not available by default
Unable to get the client statedump, as /var/run/gluster directory is not avai...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milind Changire
:
Depends On:
Blocks: 1298118 1302202
  Show dependency treegraph
 
Reported: 2016-01-27 01:52 EST by Milind Changire
Modified: 2016-06-16 09:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1298118
: 1302202 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milind Changire 2016-01-27 01:52:28 EST
+++ This bug was initially created as a clone of Bug #1298118 +++

Description of problem:
-----------------------
/var/run/gluster should automatically created after installing glusterfs fuse client rpms

Consequences of this issue is that the user unable to get the to get the statedump of fuse mount process ( client side statedump )

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1.1 ( glusterfs-3.7.1-16.el7 )

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Look for the director /var/run/gluster
(ie) ls /var/run/gluster

Actual results:
---------------
/var/run/gluster directory is not available after install client rpms

Expected results:
-----------------
/var/run/gluster should be created by the client rpms

Additional info:
----------------
Consequence of this issue would be user unable to get the client statedump

Workaround is to create : /var/run/gluster and then initiate statedump

--- Additional comment from Milind Changire on 2016-01-14 00:21:45 EST ---

As per downstream glusterfs.spec.in, /var/run/gluster is packaged only with the glusterfs-server RPM and specifically excluded for non-server RPM packaging. So any client only RPM install will not have that directory created.

Also, as per Niels comment for his upstream patch on making /var/run/gluster available, it should have been made available for native client installs as well ... but its not so in downstream packaging.

I'll have to move the directory packaging in downstream RPMs to a common RPM like the primary package 'glusterfs'.

Is this acceptable?

--- Additional comment from Niels de Vos on 2016-01-25 10:03:02 EST ---

(In reply to Milind Changire from comment #1)
...
> I'll have to move the directory packaging in downstream RPMs to a common RPM
> like the primary package 'glusterfs'.
> 
> Is this acceptable?

Yes, that should be acceptable. Please make sure to file a bug+patch for this in upstream as well if the problem exists there still.
Comment 1 Vijay Bellur 2016-01-27 02:34:15 EST
REVIEW: http://review.gluster.org/13296 (build: make /var/run/gluster available everywhere) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2016-02-05 08:05:34 EST
REVIEW: http://review.gluster.org/13296 (build: make /var/run/gluster available everywhere) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)
Comment 3 Vijay Bellur 2016-02-20 05:20:34 EST
COMMIT: http://review.gluster.org/13296 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 759b63536c676f4b4fa135ea62d74dff021778e4
Author: Milind Changire <mchangir@redhat.com>
Date:   Wed Jan 27 12:59:58 2016 +0530

    build: make /var/run/gluster available everywhere
    
    /var/run/gluster was only avialable with glusterfs-server package.
    Move it to primary glusterfs package so that client installations as
    well as server installations can generate state-dump in that directory.
    
    Change-Id: I1cdd2c5118ac657b2dab4f9669c6657484b8c600
    BUG: 1302200
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/13296
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Niels de Vos 2016-06-16 09:55:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.