Bug 1302212 - [RFE] multiple IdentityProviders for browser login
[RFE] multiple IdentityProviders for browser login
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jordan Liggitt
Johnny Liu
:
: 1322519 (view as bug list)
Depends On:
Blocks: 1267746
  Show dependency treegraph
 
Reported: 2016-01-27 03:09 EST by Alexander Koksharov
Modified: 2016-05-13 09:19 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-13 09:19:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2191901 None None None 2016-03-07 19:43 EST

  None (edit)
Description Alexander Koksharov 2016-01-27 03:09:40 EST
Description of problem:
We have found out that multiple authentication mechanisms are possible only via CLI and not via browser (console) which does not allow multiple "login" (Error: Only one identity provider can support login...") It is needed to remove that restriction.

Version-Release number of selected component (if applicable):


How reproducible:
Create several identity providers with "login: True" - master does not want to start and through error "Only one identity provider can support login".

However, it is possible to have few identity providers configured and login with "oc login".

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
no restriction for browser login.

Additional info:
Comment 6 Dan McPherson 2016-04-13 10:36:14 EDT
*** Bug 1322519 has been marked as a duplicate of this bug. ***
Comment 7 Jordan Liggitt 2016-04-14 18:37:58 EDT
Added in https://github.com/openshift/origin/pull/7039

Note You need to log in before you can comment on or make changes to this bug.