Bug 1302224 - tests fail on big endian arches
tests fail on big endian arches
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openvswitch (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Graf
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker PPCTracker
  Show dependency treegraph
 
Reported: 2016-01-27 03:58 EST by Dan Horák
Modified: 2016-09-01 09:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: openvswitch-2.5.0-4.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-01 09:35:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (93.21 KB, application/x-gzip)
2016-01-27 03:58 EST, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2016-01-27 03:58:10 EST
Created attachment 1118711 [details]
build.log

some tests are failing on big endian architectures like s390(x) and ppc64, please see attached build log for details (from http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3097897). A recent s390(x) scratch build is http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2060220


[dan@eagle tmp]$ zgrep FAILED build.log.gz 
637: tunnel_push_pop - action                        FAILED (tunnel-push-pop.at:76)
779: dpif-netdev - dummy interface                   FAILED (dpif-netdev.at:47)
780: dpif-netdev - miss upcall key matches flow_install FAILED (dpif-netdev.at:71)
785: ofproto-dpif - active-backup bonding            FAILED (ofproto-dpif.at:45)
803: ofproto-dpif - select group with hash selection method FAILED (ofproto-dpif.at:444)
833: ofproto-dpif - MPLS handling                    FAILED (ofproto-dpif.at:1975)
882: ofproto-dpif - patch ports - stack              FAILED (ofproto-dpif.at:5659)
879: ofproto-dpif - MPLS actions that result in a userspace action FAILED (ofproto-dpif.at:5499)
880: ofproto-dpif - MPLS actions that result in a drop FAILED (ofproto-dpif.at:5538)
885: ofproto-dpif megaflow - L2 classification       FAILED (ofproto-dpif.at:5719)
886: ofproto-dpif megaflow - L3 classification       FAILED (ofproto-dpif.at:5738)
884: ofproto-dpif megaflow - port classification     FAILED (ofproto-dpif.at:5702)
881: ofproto-dpif - patch ports                      FAILED (ofproto-dpif.at:5594)
887: ofproto-dpif megaflow - IPv6 classification     FAILED (ofproto-dpif.at:5757)
889: ofproto-dpif megaflow - normal                  FAILED (ofproto-dpif.at:5790)
890: ofproto-dpif megaflow - mpls                    FAILED (ofproto-dpif.at:5809)
888: ofproto-dpif megaflow - L4 classification       FAILED (ofproto-dpif.at:5776)
891: ofproto-dpif megaflow - netflow - IPv4 collector FAILED (ofproto-dpif.at:5846)
892: ofproto-dpif megaflow - netflow - IPv6 collector FAILED (ofproto-dpif.at:5847)
893: ofproto-dpif megaflow - normal, active-backup bonding FAILED (ofproto-dpif.at:5863)
894: ofproto-dpif megaflow - normal, balance-slb bonding FAILED (ofproto-dpif.at:5884)
895: ofproto-dpif megaflow - normal, balance-tcp bonding FAILED (ofproto-dpif.at:5922)
896: ofproto-dpif megaflow - resubmit port action    FAILED (ofproto-dpif.at:5941)
897: ofproto-dpif megaflow - resubmit table action   FAILED (ofproto-dpif.at:5961)
898: ofproto-dpif megaflow - goto_table action       FAILED (ofproto-dpif.at:5980)
900: ofproto-dpif megaflow - mirroring, select_vlan  FAILED (ofproto-dpif.at:6026)
901: ofproto-dpif megaflow - move action             FAILED (ofproto-dpif.at:6046)
902: ofproto-dpif megaflow - push action             FAILED (ofproto-dpif.at:6064)
899: ofproto-dpif megaflow - mirroring, select_all   FAILED (ofproto-dpif.at:6004)
903: ofproto-dpif megaflow - learning                FAILED (ofproto-dpif.at:6091)
905: ofproto-dpif megaflow - dec_ttl                 FAILED (ofproto-dpif.at:6143)
906: ofproto-dpif megaflow - set dl_dst              FAILED (ofproto-dpif.at:6164)
907: ofproto-dpif megaflow - disabled                FAILED (ofproto-dpif.at:6193)
904: ofproto-dpif megaflow - tunnels                 FAILED (ofproto-dpif.at:6123)
922: ofproto-dpif - vlan matching                    FAILED (ofproto-dpif.at:6688)
637: tunnel_push_pop - action                        FAILED (tunnel-push-pop.at:76)
779: dpif-netdev - dummy interface                   FAILED (dpif-netdev.at:47)
780: dpif-netdev - miss upcall key matches flow_install FAILED (dpif-netdev.at:71)
785: ofproto-dpif - active-backup bonding            FAILED (ofproto-dpif.at:45)
803: ofproto-dpif - select group with hash selection method FAILED (ofproto-dpif.at:444)
833: ofproto-dpif - MPLS handling                    FAILED (ofproto-dpif.at:1975)
879: ofproto-dpif - MPLS actions that result in a userspace action FAILED (ofproto-dpif.at:5499)
880: ofproto-dpif - MPLS actions that result in a drop FAILED (ofproto-dpif.at:5538)
881: ofproto-dpif - patch ports                      FAILED (ofproto-dpif.at:5594)
882: ofproto-dpif - patch ports - stack              FAILED (ofproto-dpif.at:5659)
884: ofproto-dpif megaflow - port classification     FAILED (ofproto-dpif.at:5702)
885: ofproto-dpif megaflow - L2 classification       FAILED (ofproto-dpif.at:5719)
886: ofproto-dpif megaflow - L3 classification       FAILED (ofproto-dpif.at:5738)
887: ofproto-dpif megaflow - IPv6 classification     FAILED (ofproto-dpif.at:5757)
888: ofproto-dpif megaflow - L4 classification       FAILED (ofproto-dpif.at:5776)
889: ofproto-dpif megaflow - normal                  FAILED (ofproto-dpif.at:5790)
890: ofproto-dpif megaflow - mpls                    FAILED (ofproto-dpif.at:5809)
891: ofproto-dpif megaflow - netflow - IPv4 collector FAILED (ofproto-dpif.at:5846)
892: ofproto-dpif megaflow - netflow - IPv6 collector FAILED (ofproto-dpif.at:5847)
893: ofproto-dpif megaflow - normal, active-backup bonding FAILED (ofproto-dpif.at:5863)
894: ofproto-dpif megaflow - normal, balance-slb bonding FAILED (ofproto-dpif.at:5884)
895: ofproto-dpif megaflow - normal, balance-tcp bonding FAILED (ofproto-dpif.at:5922)
896: ofproto-dpif megaflow - resubmit port action    FAILED (ofproto-dpif.at:5941)
897: ofproto-dpif megaflow - resubmit table action   FAILED (ofproto-dpif.at:5961)
898: ofproto-dpif megaflow - goto_table action       FAILED (ofproto-dpif.at:5980)
899: ofproto-dpif megaflow - mirroring, select_all   FAILED (ofproto-dpif.at:6004)
900: ofproto-dpif megaflow - mirroring, select_vlan  FAILED (ofproto-dpif.at:6026)
901: ofproto-dpif megaflow - move action             FAILED (ofproto-dpif.at:6046)
902: ofproto-dpif megaflow - push action             FAILED (ofproto-dpif.at:6064)
903: ofproto-dpif megaflow - learning                FAILED (ofproto-dpif.at:6091)
904: ofproto-dpif megaflow - tunnels                 FAILED (ofproto-dpif.at:6123)
905: ofproto-dpif megaflow - dec_ttl                 FAILED (ofproto-dpif.at:6143)
906: ofproto-dpif megaflow - set dl_dst              FAILED (ofproto-dpif.at:6164)
907: ofproto-dpif megaflow - disabled                FAILED (ofproto-dpif.at:6193)
922: ofproto-dpif - vlan matching                    FAILED (ofproto-dpif.at:6688)
637. tunnel-push-pop.at:3: 637. tunnel_push_pop - action (tunnel-push-pop.at:3): FAILED (tunnel-push-pop.at:76)
779. dpif-netdev.at:23: 779. dpif-netdev - dummy interface (dpif-netdev.at:23): FAILED (dpif-netdev.at:47)
780. dpif-netdev.at:57: 780. dpif-netdev - miss upcall key matches flow_install (dpif-netdev.at:57): FAILED (dpif-netdev.at:71)
785. ofproto-dpif.at:9: 785. ofproto-dpif - active-backup bonding (ofproto-dpif.at:9): FAILED (ofproto-dpif.at:45)
803. ofproto-dpif.at:418: 803. ofproto-dpif - select group with hash selection method (ofproto-dpif.at:418): FAILED (ofproto-dpif.at:444)
833. ofproto-dpif.at:1543: 833. ofproto-dpif - MPLS handling (ofproto-dpif.at:1543): FAILED (ofproto-dpif.at:1975)
879. ofproto-dpif.at:5472: 879. ofproto-dpif - MPLS actions that result in a userspace action (ofproto-dpif.at:5472): FAILED (ofproto-dpif.at:5499)
880. ofproto-dpif.at:5508: 880. ofproto-dpif - MPLS actions that result in a drop (ofproto-dpif.at:5508): FAILED (ofproto-dpif.at:5538)
881. ofproto-dpif.at:5546: 881. ofproto-dpif - patch ports (ofproto-dpif.at:5546): FAILED (ofproto-dpif.at:5594)
882. ofproto-dpif.at:5621: 882. ofproto-dpif - patch ports - stack (ofproto-dpif.at:5621): FAILED (ofproto-dpif.at:5659)
884. ofproto-dpif.at:5690: 884. ofproto-dpif megaflow - port classification (ofproto-dpif.at:5690): FAILED (ofproto-dpif.at:5702)
885. ofproto-dpif.at:5708: 885. ofproto-dpif megaflow - L2 classification (ofproto-dpif.at:5708): FAILED (ofproto-dpif.at:5719)
886. ofproto-dpif.at:5726: 886. ofproto-dpif megaflow - L3 classification (ofproto-dpif.at:5726): FAILED (ofproto-dpif.at:5738)
887. ofproto-dpif.at:5745: 887. ofproto-dpif megaflow - IPv6 classification (ofproto-dpif.at:5745): FAILED (ofproto-dpif.at:5757)
888. ofproto-dpif.at:5764: 888. ofproto-dpif megaflow - L4 classification (ofproto-dpif.at:5764): FAILED (ofproto-dpif.at:5776)
889. ofproto-dpif.at:5782: 889. ofproto-dpif megaflow - normal (ofproto-dpif.at:5782): FAILED (ofproto-dpif.at:5790)
890. ofproto-dpif.at:5797: 890. ofproto-dpif megaflow - mpls (ofproto-dpif.at:5797): FAILED (ofproto-dpif.at:5809)
891. ofproto-dpif.at:5846: 891. ofproto-dpif megaflow - netflow - IPv4 collector (ofproto-dpif.at:5846): FAILED (ofproto-dpif.at:5846)
892. ofproto-dpif.at:5847: 892. ofproto-dpif megaflow - netflow - IPv6 collector (ofproto-dpif.at:5847): FAILED (ofproto-dpif.at:5847)
893. ofproto-dpif.at:5849: 893. ofproto-dpif megaflow - normal, active-backup bonding (ofproto-dpif.at:5849): FAILED (ofproto-dpif.at:5863)
894. ofproto-dpif.at:5870: 894. ofproto-dpif megaflow - normal, balance-slb bonding (ofproto-dpif.at:5870): FAILED (ofproto-dpif.at:5884)
895. ofproto-dpif.at:5891: 895. ofproto-dpif megaflow - normal, balance-tcp bonding (ofproto-dpif.at:5891): FAILED (ofproto-dpif.at:5922)
896. ofproto-dpif.at:5929: 896. ofproto-dpif megaflow - resubmit port action (ofproto-dpif.at:5929): FAILED (ofproto-dpif.at:5941)
897. ofproto-dpif.at:5948: 897. ofproto-dpif megaflow - resubmit table action (ofproto-dpif.at:5948): FAILED (ofproto-dpif.at:5961)
898. ofproto-dpif.at:5968: 898. ofproto-dpif megaflow - goto_table action (ofproto-dpif.at:5968): FAILED (ofproto-dpif.at:5980)
899. ofproto-dpif.at:5987: 899. ofproto-dpif megaflow - mirroring, select_all (ofproto-dpif.at:5987): FAILED (ofproto-dpif.at:6004)
900. ofproto-dpif.at:6010: 900. ofproto-dpif megaflow - mirroring, select_vlan (ofproto-dpif.at:6010): FAILED (ofproto-dpif.at:6026)
901. ofproto-dpif.at:6033: 901. ofproto-dpif megaflow - move action (ofproto-dpif.at:6033): FAILED (ofproto-dpif.at:6046)
902. ofproto-dpif.at:6053: 902. ofproto-dpif megaflow - push action (ofproto-dpif.at:6053): FAILED (ofproto-dpif.at:6064)
903. ofproto-dpif.at:6071: 903. ofproto-dpif megaflow - learning (ofproto-dpif.at:6071): FAILED (ofproto-dpif.at:6091)
904. ofproto-dpif.at:6098: 904. ofproto-dpif megaflow - tunnels (ofproto-dpif.at:6098): FAILED (ofproto-dpif.at:6123)
905. ofproto-dpif.at:6131: 905. ofproto-dpif megaflow - dec_ttl (ofproto-dpif.at:6131): FAILED (ofproto-dpif.at:6143)
906. ofproto-dpif.at:6150: 906. ofproto-dpif megaflow - set dl_dst (ofproto-dpif.at:6150): FAILED (ofproto-dpif.at:6164)
907. ofproto-dpif.at:6171: 907. ofproto-dpif megaflow - disabled (ofproto-dpif.at:6171): FAILED (ofproto-dpif.at:6193)
922. ofproto-dpif.at:6678: 922. ofproto-dpif - vlan matching (ofproto-dpif.at:6678): FAILED (ofproto-dpif.at:6688)



Version-Release number of selected component (if applicable):
openvswitch-2.4.0-1.fc24
but fails since openvswitch-2.3.1-3.git20150327.fc23
Comment 1 Jan Kurik 2016-02-24 09:21:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Dan Horák 2016-08-24 05:27:54 EDT
test-suite has been disabled on big endian arches, as recommended in https://bugzilla.redhat.com/show_bug.cgi?id=1105458#c10 (it's known to be broken)
Comment 3 Fedora Update System 2016-08-24 05:28:40 EDT
openvswitch-2.5.0-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-11c3a4496e
Comment 4 Fedora Update System 2016-08-25 05:29:12 EDT
openvswitch-2.5.0-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-11c3a4496e
Comment 5 Fedora Update System 2016-09-01 09:35:51 EDT
openvswitch-2.5.0-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.