Bug 1302236 - Uncaught exception occurred. in the UI while choosing CPU Architecture as 'undefined' in the New Cluster dialog
Uncaught exception occurred. in the UI while choosing CPU Architecture as 'un...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2.6
x86_64 Linux
unspecified Severity low (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Greg Sheremeta
Pavel Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 04:29 EST by Michael Burman
Modified: 2016-07-05 03:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:39:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
record (12.94 MB, application/x-gzip)
2016-01-27 04:35 EST, Michael Burman
no flags Details
screenshot (265.43 KB, application/x-gzip)
2016-01-27 04:40 EST, Michael Burman
no flags Details
symbolMap (1.78 MB, application/x-gzip)
2016-01-27 04:40 EST, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57439 master MERGED webadmin: fixed NullPointerException in FilteredListModel 2016-05-16 08:26 EDT

  None (edit)
Description Michael Burman 2016-01-27 04:29:14 EST
Description of problem:
Uncaught exception occurred. in the UI while choosing CPU Architecture as 'undefined' in the New Cluster dialog. 

The exception occurred in the [New Cluster] dialog, when choosing/switching the CPU Architecture as 'undefined' from 'x86_64' or 'ppc64'. 

Version-Release number of selected component (if applicable):
3.6.2.6-0.1.el6

How reproducible:
100

Steps to Reproduce:
1. Under [Clusters] main tab press New Cluster and choose CPU Architecture as 'x86_64', then switch back to 'undefined'. Switch to 'x86_64' and switch back to 'undefined'.

Actual results:
Every time choosing and switching the CPU Architecture as 'undefined' from 'x86_64' or 'ppc64' an Uncaught exception occurred in the fronted UI. 

Expected results:
Shouldn't invoke exception
Comment 1 Michael Burman 2016-01-27 04:35 EST
Created attachment 1118713 [details]
record
Comment 2 Michael Burman 2016-01-27 04:40 EST
Created attachment 1118714 [details]
screenshot
Comment 3 Michael Burman 2016-01-27 04:40 EST
Created attachment 1118715 [details]
symbolMap
Comment 4 Oved Ourfali 2016-01-29 11:55:15 EST
Alona, shouldn't this be a network bug?
Comment 5 Oved Ourfali 2016-02-03 06:32:58 EST
(In reply to Oved Ourfali from comment #4)
> Alona, shouldn't this be a network bug?

My bad.
I've put a needinfo on the wrong bug.
Comment 6 Sandro Bonazzola 2016-05-02 05:48:57 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 7 Pavel Novotny 2016-06-24 10:27:57 EDT
Verified in 
rhevm-4.0.0.6-0.1.el7ev.noarch (build 4.0.0-19).
ovirt-engine-webadmin-portal-4.0.0.6-0.1.el7ev.noarch

Following reproducer in comment 0, I tried all the state transitions of the cluster CPU arch:
- undefined -> x86_64
- undefined -> ppc64
- x86_64 -> undefined
- ppc64 -> undefined
- ppc64 -> x86_64
- x86_64 -> ppc64

No UI exception has been thrown in any of the cases above.
Comment 8 Sandro Bonazzola 2016-07-05 03:39:50 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.