Bug 130224 - I/O very very slow with newer kernels
I/O very very slow with newer kernels
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-18 06:41 EDT by Lorenzo Luconi Trombacchi
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 02:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lorenzo Luconi Trombacchi 2004-08-18 06:41:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
First of all my hardware configuration:
Athlon64 3200+
MB MSI chipset VIA
Controller RAID SATA 3Ware 8506-4LP with 3 HDD SATA 160 Gbyte Maxtor
Controller VIA SATA with 1 HDD SATA 250 Gbyte Maxtor
Realtek Ethernet 1 Gbit
512 Mbyte RAM
All HDD partitions use LVM2 and no RAID Software

The Problem:
In these days I tried to upgrade the kernel of my Fedora Core 2
(2.6.5-1.358), but after kernel upgrade I found a problem in I/O
operation.
The I/O operations with newer kernels become very very very slow in
particular in write operation. Moreover sometimes during I/O operation
(like copying a file) the load average grows up to 6 and more and PC
become unusable. I tried to copy files bigger and smaller from one
partition to another one or using HDD connected to the different
controller or copying file using network (samba and ftp) but the copy
time (in particular in writing operation) are 10 or 100 times (or
more?!) slower than the same operation using kernel 2.6.5-1.358.

I have tested these kernels and I found the same problem:
kernel-2.6.6-1.435.2.3
kernel-2.6.7-1.494.2.2
kernel-2.6.7-1.517 (development)


Some months ago I found the same problems with Fedore Core 2 Test
release (with different kernel and different HW configuration) and I
wrote a message to fedora-devel-list:
http://www.redhat.com/archives/fedora-devel-list/2004-March/msg00898.html









Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Installing newer kernel for FC2
2.Reboot with the new kernel
3.
    

Additional info:
Comment 1 Dave Jones 2005-04-16 02:02:56 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.