Bug 1302256 - neutron-server does not start on Mitaka-2 when enabling LBaaS
neutron-server does not start on Mitaka-2 when enabling LBaaS
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Javier Peña
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 05:14 EST by Javier Peña
Modified: 2017-06-18 02:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 02:12:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 272994 None None None 2016-01-27 06:09 EST

  None (edit)
Description Javier Peña 2016-01-27 05:14:38 EST
Description of problem:
Using the Mitaka-2 test repos, an all-in-one installation of packstack with 
CONFIG_LBAAS_INSTALL=y fails with the following error message:

ERROR : Error appeared during Puppet run: 192.168.122.17_neutron.pp
Error: Could not start Service[neutron-server]: Execution of '/usr/bin/systemctl start neutron-server' returned 1: Job for neutron-server.service failed because the control process exited with error code. See "systemctl status neutron-server.service" and "journalctl -xe" for details.
You will find full trace in log /var/tmp/packstack/20160127-102648-jPi06H/manifests/192.168.122.17_neutron.pp.log

/var/log/neutron/server.log shows the following error message 

2016-01-27 10:57:46.369 18043 ERROR neutron.services.service_base [-] No providers specified for 'LOADBALANCER' service, exiting
Version-Release number of selected component (if applicable):

How reproducible: always

Additional info: this seems to be related to the puppet-neutron bug described in https://bugs.launchpad.net/puppet-neutron/+bug/1535382/ . Manually adding the following line in /etc/neutron/neutron_lbaas.conf fixed the issue:


[service_providers] service_provider=LOADBALANCER:Haproxy:neutron_lbaas.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
Comment 1 Javier Peña 2016-01-27 06:09:04 EST
Proposed https://review.openstack.org/272994 with a fix.
Comment 2 Mike McCune 2016-03-28 18:48:26 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Christopher Brown 2017-06-17 15:03:44 EDT
Javier,

It looks like this was merged so this can be closed?

Note You need to log in before you can comment on or make changes to this bug.