Bug 1302276 - Failed to install rpm packages with specified version
Failed to install rpm packages with specified version
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 05:57 EST by Anping Li
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:37:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2016-01-27 05:57:28 EST
Description of problem:
Ansible failed to install atomic-openshift-master 3.1.0.4. Because ansible already installed the latest atomic-openshift rpm as dependency of oc client before install atomic-openshift-master, that would cause version conflict. Seem like when installing oc client, installer did not apply the specified version, is using "latest" version.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.35

How reproducible:
always

Steps to Reproduce:
1. register to RHSM channel and enable ose-3.1 channel
2. set openshift_pkg_version=-3.1.0.4 in ansible inventory file
3. ansible-playbook -i  /root/config/ose3104 /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml


Actual results:
TASK: [openshift_master | Install Master package] ***************************** 
failed: [10.14.6.133] => {"changed": true, "rc": 1, "results": ["Loaded plugins: product-id, search-disabled-repos, subscription-manager\nResolving Dependencies\n--> Running transaction check\n---> Package atomic-openshift-master.x86_64 0:3.1.0.4-1.git.15.5e061c3.el7aos will be installed\n--> Processing Dependency: atomic-openshift = 3.1.0.4-1.git.15.5e061c3.el7aos for package: atomic-openshift-master-3.1.0.4-1.git.15.5e061c3.el7aos.x86_64\n--> Finished Dependency Resolution\nError: Package: atomic-openshift-master-3.1.0.4-1.git.15.5e061c3.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)\n           Requires: atomic-openshift = 3.1.0.4-1.git.15.5e061c3.el7aos\n           Installed: atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos.x86_64 (@rhel-7-server-ose-3.1-rpms)\n               atomic-openshift = 3.1.1.6-1.git.0.b57e8bd.el7aos\n           Available: atomic-openshift-3.1.0.4-1.git.4.b6c7cd2.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)\n               atomic-openshift = 3.1.0.4-1.git.4.b6c7cd2.el7aos\n           Available: atomic-openshift-3.1.0.4-1.git.10.ec10652.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)\n               atomic-openshift = 3.1.0.4-1.git.10.ec10652.el7aos\n           Available: atomic-openshift-3.1.0.4-1.git.15.5e061c3.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)\n               atomic-openshift = 3.1.0.4-1.git.15.5e061c3.el7aos\n**********************************************************************\nyum can be configured to try to resolve such errors by temporarily enabling\ndisabled repos and searching for missing dependencies.\nTo enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf\n**********************************************************************\n\n You could try using --skip-broken to work around the problem\n You could try running: rpm -Va --nofiles --nodigest\n"]}
msg: Error: Package: atomic-openshift-master-3.1.0.4-1.git.15.5e061c3.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)
           Requires: atomic-openshift = 3.1.0.4-1.git.15.5e061c3.el7aos
           Installed: atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos.x86_64 (@rhel-7-server-ose-3.1-rpms)
               atomic-openshift = 3.1.1.6-1.git.0.b57e8bd.el7aos
           Available: atomic-openshift-3.1.0.4-1.git.4.b6c7cd2.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)
               atomic-openshift = 3.1.0.4-1.git.4.b6c7cd2.el7aos
           Available: atomic-openshift-3.1.0.4-1.git.10.ec10652.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)
               atomic-openshift = 3.1.0.4-1.git.10.ec10652.el7aos
           Available: atomic-openshift-3.1.0.4-1.git.15.5e061c3.el7aos.x86_64 (rhel-7-server-ose-3.1-rpms)
               atomic-openshift = 3.1.0.4-1.git.15.5e061c3.el7aos


FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/config.retry

10.14.6.133                : ok=165  changed=19   unreachable=0    failed=1   
localhost                  : ok=10   changed=0    unreachable=0    failed=0

Expected results:
The old packages can be installed.

Additional info:
Comment 1 Brenton Leanhardt 2016-02-01 15:21:12 EST
https://github.com/openshift/openshift-ansible/pull/1276 was merged in to openshift-ansible/master recently.  Would you mind re-testing with a clone from github?
Comment 2 Anping Li 2016-02-02 00:01:07 EST
The specified version of packages can be installed. so move bug to verified.
Comment 4 errata-xmlrpc 2016-05-12 12:37:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.