Bug 1302328 - cannot configure username and password for connection to LDAP
Summary: cannot configure username and password for connection to LDAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2
Assignee: Timothy Asir
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-27 13:54 UTC by Martin Kudlej
Modified: 2016-08-23 19:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-01-27 13:54:54 UTC
Description of problem:
LDAP server can require authentication for connection. It is not possible to configure it now in configuration for LDAP authentication.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.7-0.1.alpha1.el7.x86_64
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch
rhscon-ceph-0.0.5-0.1.alpha1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Configure AD server which requires authentication for connection

Actual results:
It is not possible to configure LDAP authentication in configuration.

Expected results:
It is possible to configure LDAP authentication in configuration and LDAP user can authenticate in USM.

Comment 1 Timothy Asir 2016-02-01 05:13:44 UTC
Patch sent to upstream for review: https://review.gerrithub.io/261751

Comment 3 Timothy Asir 2016-03-02 12:20:29 UTC
fixed in version rhscon-core-0.0.8-10.el7.x86_64

Comment 4 Jeff Applewhite 2016-03-18 18:41:37 UTC
still valid?

Comment 5 Martin Kudlej 2016-07-01 15:14:45 UTC
Tested with 
rhscon-core-0.0.29-1.el7scon.x86_64
rhscon-ui-0.0.43-1.el7scon.noarch
and it works. --> Verified

Comment 8 errata-xmlrpc 2016-08-23 19:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.